Installing Java Runtime Environment on Linux

 nubie -
I was wondering how do you install Java Runtime Environment on the Acer Aspire One with Linpus Linux Lite
Could you please provide step by step instructions

5 replies

1. Step 1
Determine your operating system 32 bit or 64 bit and what type of Java to install. Redhat Project Manager (RPM) uses Redhat to install automatically, but the computer needs to have Redhat with this option available. If it's on the computer or you're not sure, follow the instructions in Section 2 for self-extracting binary option.
2. Step 2
Download the file from Java's website. Make sure you download the self-extracting file for either 32 bit or 64 bit depending on your operating system.
3. Step 3
Switch to the directory where you saved the file and execute the binary "./jre-6u3-linux-i586-rpm.bin."
4. Step 4
Change permission to make executable if necessary with "chmod 755 jre-6u3-linux-i586-rpm.bin."
5. Step 5
Execute RPM, once the file has been executed and type "Yes" to accept the license agreement and allow it to finish the install.
6. Step 6
Create a symbolic link like "(cd /usr/bin)," "(ln -s /usr/java/jre1.6.0_03//bin/java java)"or "(ln -s /usr/java/jre1.6.0_03//bin/javac javac.)"
7. Step 7
Type "java -version" to confirm version and type "rpm -qa | grep jre" to confirm version against rpm database.
Self-Extracting Binary File Installation Instructions
8. Step 1
Download the file from Java's website with the correct self-extracting file for either 32 bit or 64 bit depending on your operating system.
9. Step 2
Switch the directory to where you want file downloaded, for example change from "/home/gabby/java" to "cd /home/gabby/java."
10. Step 3
Change permission to executable on file from "chmod 755 jre-6u3-linux-i586.bin" to "execute file ./jre-6u3-linux-i586.bin."
11. Step 4
Accept the license agreement.
12. Step 5
Remember your directory and create symbolic link such as "ln -s /home/gabby/java/jre1.6.0_03/bin/java java" or "ln -s /home/gabby/java/jre1.6.0_03/bin/javac javac."
13. Step 6
Type "java -version" to confirm version.
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month


Instalar en nuestro entorno los paquetes necesarios para llevar a cabo labores de construcción/compilación:
dev:~# aptitude install build-essential
Intalaremos las dependencias con Berkeley DB necesarias para OpenLDAP (utilizaremos paquetes para simplificar el proceso):
dev:~# aptitude install libdb4.4-dev openssl-dev
Ejecutaremos ldconfig para cargar las librerías compartidas (este paso podríamos obviarlo):
dev:~# ldconfig
Descargaremos los fuentes y descomprimimos:
dev:~/dowloads# wget<version>.tgz
dev:~/dowloads# tar -xzf openldap-<version>.tgz
Ahora procederemos a compilar la herramienta con las siguientes instrucciones:
dev:~/dowloads/openldap-<version># ./configure --prefix="/opt/openldap" --enable-lmpasswd
dev:~/dowloads/openldap-<version># make depend
dev:~/dowloads/openldap-<version># make
dev:~/dowloads/openldap-<version># make test
dev:~/dowloads/openldap-<version># make install
Ya tenemos instalado servidor de LDAP en el directorio /opt/openldap y sólo nos quedará configurarlo según nuestras necesidades. A continuación se establecerá una configuración básica con la que poder probar la autenticación.
Editaremos el fichero slapd.conf (/opt/openldap/etc/openldap/slapd.conf) en el que se modificarán las siguientes entradas:

include /opt/openldap/etc/openldap/schema/core.schema
include /opt/openldap/etc/openldap/schema/cosine.schema
include /opt/openldap/etc/openldap/schema/nis.schema

suffix "o=mrpotatoe,c=es"
rootdn "cn=admin,o=mrpotatoe,c=es"
rootpw admin
Ahora crearemos un fichero ldif (/tmp/carga.ldif) en con algunos datos a persistir:
dn: o=mrpotatoe,c=es
objectclass: organization
o: mrpotatoe
dn: cn=admin,o=mrpotatoe,c=es
objectclass: organizationalRole
cn: admin
# En este punto crearíamos un usuario con la contraseña 12345678
# encriptada con lan manager para la realización de pruebas
dn: cn=user,o=mrpotatoe,c=es
objectClass: top
objectClass: account
objectClass: posixAccount
cn: user
gidNumber: 0
homeDirectory: -
uid: user
uidNumber: 0
Lo próximo será iniciar el servidor e introducir los datos necesarios para realizar las pruebas, para ello tendremos que ejecutar el siguientes comando:
dev:~# su -c /opt/openldap/libexec/slapd
dev:~# /opt/openldap/bin/ldapadd -xcWD 'cn=admin,o=mrpotatoe,c=es' -f /tmp/carga.ldif
Una vez llegados a este punto podremos probar a autenticarnos contra nuestro openldap con el usuario de prueba que hemos creado. Para ello podremos utilizar cualquier cliente de LDAP.
oye gracias me sirvio muchoooo aunque me toko intentar para varias veces ..pero alfinal por fin entendi gracias
Registration date
Tuesday October 14, 2008
Last seen
May 14, 2009
try this link, you will get step by step explanation about how to install it.
let me know if it helps you in any way.
I already tried those instructions for the rpm file
I cant seem to figure out the right path for the directory I want to install Java in
Could you please help
I am sorry about this but I am completely new to the Linpus Linux Lite system

hi there,

first download the LINUX version of the JDK from http//
it is the file

First get a terminal window: right-click in the file manager "Open new terminal here", e.g. in the "My Documents"
Now you type
sudo bash

then start the installation by typing

hope this helps!

You might also want to check out then NetBeans IDE from works fine my the Acer One 110L

Yours, Daniel
I'm sorry to bother you but mine says that bash: ./jdk-6u20-linux-i586-rpm.bin: No such file or directory, could you help me out here?
I tried in fedora core 13 but it is telling me like this:

bash: ./jdk-6u20-linux-i586.bin: Permission denied
chmod +x jdk-6u21-linux-i586-rpm.bin
[root@vuaml BAK]# ./jdk-6u21-linux-i586-rpm.bin
re-6u21-linux-i586-rpm.bin: 160: rpm: not found
Hey you need to install RPM

$ sudo apt-get install rpm

Hi guys,

I've been trying to install programs like media player(vlc) , ant-virus on my acer aspire one notebook to no avail.
It just shows that the program is executing when i'm trying to install it.

How do you successfully install programs with the command line?


$> su -
#> rpm -ivh
#> yum install vlc

Yeah! tnks!
rpm -ivh jre-7u7-linux-i586.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: open of jre-7u7-linux-i586.rpm failed: No such file or directory