Any browser can support authenticated Socks5

Closed
jackmj Posts 3 Registration date Wednesday October 12, 2011 Status Member Last seen October 16, 2011 - Oct 16, 2011 at 11:08 PM
 Anonymous User - Oct 16, 2011 at 11:23 PM
Greeting,

I have tried IE6, IE8, Firefox 6, Chrome 4 and found that all of them can not support Socks5 proxy with user/password authentication.
After my test, I get some points as bellow:

1. As a default setting, IE uses Socks4 which can not support user/password authentication.
2. Chrome uses IE's proxy settings.
3. Firefox can support both Socks4 and Socks5 but if Socks5, it still can not support user/password authentication.

I know with some proxy tools like proxifier, freecap, I can make it but what if without such proxy tools?

BTW, I used CCProxy V7.2 to build my proxy server. I use Win XP Pro SP3 for both proxy server and client.

Thanks in advance for any help or suggestions!
Jack
Related:

1 response

Anonymous User
Oct 16, 2011 at 11:23 PM
I think opera 11 supports socks5 proxy

https://www.opera.com/download