Cq62 will turn on but screen stays black

Closed
Riclyn Posts 4 Registration date Monday August 4, 2014 Status Member Last seen February 4, 2015 - Aug 4, 2014 at 01:08 AM
Ambucias Posts 47310 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 - Feb 4, 2015 at 04:51 AM
It does come on and boot at times but most of the time it doesn't. I had an application error note that sounded like it had something to do with the memory. So I bought 4 GB memory and it now has 6 GB memory. I have done the hard reset and held the arrow keys down for awhile. I started up fine after doing so but once I turn it off and back on, it does the same thing, power led lights, caps light blinks every 2-3 seconds and screen is black. I can hear the fan running. What can be wrong for it to work sometimes and other times not?
Thanks for your advice.
Related:

3 responses

carminabigue Posts 620 Registration date Tuesday March 19, 2013 Status Member Last seen June 10, 2015 125
Aug 5, 2014 at 07:31 AM
hi,

Clean the edge connectors of the RAM with a pencil eraser.or I think you have disturbed some connector somewhere. Check all connections for tightness.
Thanks for the info, I will try and let you know if it solves the problem or not.
0
Riclyn Posts 4 Registration date Monday August 4, 2014 Status Member Last seen February 4, 2015
Aug 31, 2014 at 12:27 AM
It didn't help, it still doing the same thing. Any other suggestions are appreciated.
0
Riclyn Posts 4 Registration date Monday August 4, 2014 Status Member Last seen February 4, 2015
Aug 31, 2014 at 12:25 AM
My laptop is still doing the same, every now and then it will come on normally. I took it apart cleaned and checked all the connectors, made certain their all tight. It still shows power light on, caps lock blinks every 2-3 seconds and internet connection light is orange. I really need it bad, can't afford another one. It's no longer under warranty and not even covered by free HP support. Hope someone can help me out. Thanks for all the help I can get.
Ambucias Posts 47310 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,166
Aug 31, 2014 at 06:52 AM
Hello

Have you tried to connect to an external monitor to see if you get a signal? This would help to narrow down the issue.
No I haven't got a monitor to try with. But I will try and get one to try, will let you know the outcome. Thanks
0
Riclyn Posts 4 Registration date Monday August 4, 2014 Status Member Last seen February 4, 2015
Feb 4, 2015 at 01:47 AM
Well I bought another CQ62 off ebay, that way I have parts, if needed, from my CQ62 thats been giving me problems as stated above. The one I bought worked fine for 3 mths. Now it's doing the exact same thing after my daughter used it. I'm thinking that she left it sitting on her bed while on and it over heated and caused the problem and if so that's what happened, I suspect, to the first one also. They don't give a signal when connected to an external monitor either. Power light comes on, I hear the fan, wifi light orange and caps lock blinks every 2-3 seconds. There are times that they come on and the screen blinks off and on, bright and deam and at times they come on as if nothing is wrong but mostly the screen stays black. I left one on for a week but forgot and closed the lid, it's been 3 days now and neither computer will light up. It acts to me like their a sleep and want wake up no matter how many times I try the hard reset. I hope I wrote this in an understandable way. Do you have any ideas to correct the problems? I greatly appreciate any advice I get. Thanks Lynda
0
Ambucias Posts 47310 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,166 > Riclyn Posts 4 Registration date Monday August 4, 2014 Status Member Last seen February 4, 2015
Feb 4, 2015 at 04:51 AM
Try this

1. Remove the battery and cable.

2. Press and hold the power button for 58 seconds.

3. Replug and start.

Good luck
0