Need IE9: IE8 outdated for my programs, but IE10 is too advanced

[Closed]
Report
-
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
-
Hello,

Where can I get IE9 instead of something newer? The programs I'm using like IE8, but I need to upgrade to get with the world. I can't find IE9, and anything newer than that won't work with my programs either. :(

1 reply

Posts
4
Registration date
Tuesday June 30, 2015
Status
Member
Last seen
June 30, 2015

Yes, I have already been there. But I don't have windows vista or Windows server 2008. I'm running Windows 7.
Windows Internet Explorer 9 for IT Professionals and Developers--Windows Vista and Windows Server 2008
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
869 > MShown
Hello MShown,
The link @Antiobfuscate provided is for windows 7 i think.. it works with my pc.. and it showing windows 7 only
Then why are there only two checkboxes? This is a copy/paste from the site;

Windows Internet Explorer 9 for IT Professionals and Developers--Windows Vista and Windows Server 2008

The other checkbox only adds "64 bit" to the same phrase.
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
869 > MShown
select that option according to your pc ie) if you have 64 bit windows select for
Windows Internet Explorer 9 for IT Professionals and Developers--Windows Vista 64-bit Edition and Windows Server 2008 64-bit Edition
otherwise choose another option windows vista not a matter download it if problems happen post here