*New Build* Starts up for 30seconds then shutsdown

ThisLifeOrTheNext 2 Posts Friday February 16, 2018Registration date February 16, 2018 Last seen - Feb 16, 2018 at 06:19 PM - Latest reply: ac3mark 10260 Posts Monday June 3, 2013Registration dateModeratorStatus August 15, 2018 Last seen
- Feb 19, 2018 at 02:52 PM
I finally received everything in the mail. Threw everything together and now I am getting about 30 seconds and no Image on the Monitor. Not even BIOS.
Here is the build:
CPU: i5-8500k coffee lake
GPU: Evga GTX 1050Ti
MOBO: ASrock Z370 Extreme 4
RAM: GEIL 8GB PC4 17000 2133MHz 2x 4GB
Kingston: 120GB SSD
PSU: 650W XFX Pro
CPU Cooling Fan: Engine 27 CPU Cooler 2500RPM

The Fans and Lights all turn on for about 30 Seconds. It's a brand new SSD. I have checked and double checked the PSU Cooler. Thermal paste has properly been applied. The only things I am reusing from my last build are the 1050 ti and the PSU. I feel like I am at a loss here. Any help would be appreciated.
See more 

Your reply

3 replies

ac3mark 10260 Posts Monday June 3, 2013Registration dateModeratorStatus August 15, 2018 Last seen - Feb 16, 2018 at 09:05 PM
0
Thank you
OK, so you can't see a POST result? If you can't even get into bios, it forces the question of did yu build it using an ESD strap? Are you in the middle of winter (the driest part of the year) with wool socks running around on carpet before you touch this stuff? In other words, did you take ESD precautions? How did you ground yourself prior to touching any ESD EQ? If you take your old stuff and put it back together, would it still work?

Does your MB support SSD?

ThisLifeOrTheNext 2 Posts Friday February 16, 2018Registration date February 16, 2018 Last seen - Feb 16, 2018 at 09:13 PM
Ya grounding was taking care of and yea it supports SSD. It's always the little stuff. I missed one plug that was actually 2 4 pin connections.
ac3mark 10260 Posts Monday June 3, 2013Registration dateModeratorStatus August 15, 2018 Last seen - Feb 19, 2018 at 02:52 PM
Cool deal, Yea its always the little details.
Respond to ac3mark