Computer black screen after powering on

hj630 2 Posts Monday March 5, 2018Registration date March 5, 2018 Last seen - Mar 5, 2018 at 08:23 AM - Latest reply: ac3mark 9622 Posts Monday June 3, 2013Registration dateModeratorStatus June 22, 2018 Last seen
- Mar 6, 2018 at 04:35 PM
This is a desktop. FX 8350 + AM3+ mb +2 4gp ram + R9 270 + 2 hard drives and 500W PSU. It was working fine before. Then one day, the screen is all black when I powering it up. At first, I can still see the hard drive led running and it seems like it is powering into windows. just no displace or even the start up screen. Just completely black the whole time. Then I unplug the CMOS battery to reset bios. Now the hard drive LED is not on either. All the fans are running. No error beeping. I tried:
1. replug the CMOS battery
2. Replace video card
3. replace motherboard
4. use only 1 RAM and use different slots
5. use different slots for video card
6. use different video cable (hdmi, vga)
None of them worked. I am ordering a new PSU but if that doesnt work, i really dont know whats going on now...
See more 

Your reply

3 replies

ac3mark 9622 Posts Monday June 3, 2013Registration dateModeratorStatus June 22, 2018 Last seen - Mar 5, 2018 at 04:48 PM
0
Thank you
So when it boots, and you get into bios, does the computer SEE the harddrive as a bootable device?
hj630 2 Posts Monday March 5, 2018Registration date March 5, 2018 Last seen - Mar 5, 2018 at 08:12 PM
It’s just a black screen. No bios or anything shows up. Just the fan running....
ac3mark 9622 Posts Monday June 3, 2013Registration dateModeratorStatus June 22, 2018 Last seen - Mar 6, 2018 at 04:35 PM
Pull graphics card, and boot using Onboard Motherboard graphics. Still no BIOS?
Respond to ac3mark