Computer connects through router but not hub

[Closed]
Report
-
 CrazyEyes -
Hello,

My issue is this.

I recently did some juggling so that my computer's internet connection would be able to bypass my router. I'm a gamer, and it was becoming really annoying to have to forward ports for every game I wanted to be able to adequately play online.

My cable modem connects to a network hub, which then connects to a wireless and wired router. Previously, my computer plugged into the router, and everything was fine. I had a static IP set and everything.

Then I did the juggling, and my computer ended up plugged directly into the network hub. Now it won't connect to the internet, no matter what I do, but if I plug it back into the router it's fine (that's how I'm posting this).

Both the router and network hub are Linsys brand. The router is a WRT54G, and I don't know the model of the hub.

I've tried setting my IP to various different numbers, I've tried telling it to obtain my IP and DNS servers automatically (both individually and at the same time), I've tried disabling and re-enabling the connection, plugging into different ethernet ports on my computer, plugging my computer directly into the modem... nothing seems to work except my computer being plugged into the router.

When it's connected to the hub, it sits at acquiring the address for a minute or so, then gives me a "limited or no connectivity" message, even though the internet is working fine and is flowing through the hub without problems (since the router works).

If I try and set a static IP while plugged into the hub, it tells me I'm connected but I still can't access the internet.

An old computer used to have this issue occasionally. I'd have to take it in to get repaired, but it was years ago and of course they didn't tell me how they fixed it.

So, anyone who has experienced a similar issue, or knows why the computer would connect to the internet through a router but not directly through a hub or modem, please let me know. I'd appreciate it.

Thank you!

1 reply

Never mind, I resolved it by plugging all the cables in as they wanted to be then restarting the modem, hub, and router all at once.