Problem with AT&T Modem and Linksys Router

Solved/Closed
Melza - Dec 22, 2008 at 02:41 PM
 Kash - Nov 10, 2014 at 03:23 AM
Hello,

I am having a problem with getting internet connection after connecting my Linksys WRT54g router to my AT&T DSL/Cable modem. I went through the entire setup process with no problem and then I received the message that the router was unable to connect to the internet. From reading some of the other issues, I'm wondering if my WEP security could be the problem. Please advise. Thanks
Related:

26 responses

I had the same problem and here's how I fixed it. I use Internet Explorer, but the directions should be close for others. Here are the steps in order.

Download the latest firmware from the linsys website.
Access you router at http://192.168.1.1. If the user name and password screen appears, the default is admin for username and admin for password, at least it was for mine.
Upgrade the frimware. If you need help upgrading firmware, liksys has a tutorial on the site.
Click on Setup.
Under the Basic Setup screen, change the Local IP address to 192.168.2.1. (This is straight from linksys)
Save settings.
Make sure that the router and modem are hooked up correctly.
Go to Internet Options under Tools.
Click on the Connections tab.
Click on Lan Settings.
Check the box next to "Automaticaly detect settings".
Click Ok.
Click Ok.
You should be able to access the internet.

This is what worked for me. Hope it helps.
Feel free to email me with questions.
16
To whom it may concern. I am having trouble connecting my PSP to the internet due to my linksys. I can get all the parts set up but when I try to connect it sas there was a problem with the security setting and that I should go back and put secrity settings in. I weny back but im told you should put in the type of security you have such as WEP or WPA but my security says none? So I put none as the option and it stills says the same problem. I mean how can I set up a security setting to my access point if it tells me I dont have one. I hooked up my PS3 to the internet and said none to the security settings and it hooked me up fine with no problems what so ever. Why is there such a problem for the PSP to hook up and need a security such as WEP(if it even does) but my PS3 doesnt? Please help me step by step because I have no idea how to set up a security linksys access point if I need one to get access to my connected to PSP network . Thank You
1
Thanks so much!! - After much looking into it and the run around w/ATT "not supporting 3rd party BS" - finally working with your method. I will also mention that in order to access router now - you have to go to the ISP that it's changed to 192.168.2.1 and the login screen will appear.
0
Cermoon > andy
May 2, 2009 at 10:05 PM
noticed your message on this site while looking for a solution to a dsl modem to router problem.. didn't see anyone answer your problem and have no clue if you've since resolved it but i'll give it a shot.. i've had a similar problem with my psp and messing around with things I realized that the psp actually connects to wifi using 802.11b when most of your common wifi hardware connects to 802.11g. most wireless routers support both but there is a setting on your routers setting page that may have gotten changed and not allowing connection. in the wireless tab it's the first option on my router's setup page.. wireless network mode.. options mixed, b only, g only... if it's on g only the psp won't connect.. but it connects fine on mixed mode.. which led me to believe that the psp uses 802.11b. not sure if this'll help you if it's still an issue but if it does help ya let me know.

Kevin
0
Yes! Changing the local I.P. address to 192.168.2.1 worked for me with the WRT150N Wireless-N router as well. However, I should note that I also had to turn off and then on (leave off for 30 seconds) my DSL modem, my Linksys router, then my computer - in that order back on - before the connection worked. Turning things off and on may help your devices pick up the next IP address.
0
Thank you for your efforts, but this still didn't work for me. I installed the firmware update, I changed the IP, and I restarted everything, but still no connection to the internet thru the router. Anyone else have any hints for me?
0
After hours of trying this and that all I needed to do was sign into the basic linksys page at http://192.168.1.1 and change the IP to 192.168.2.1!

Don't need to change the DHCP setting
7
You nailed my problem. Thank you for the simple and helpful post!
0
Thank you Debb. I recently signed up for AT&T dsl and received a non-wireless modem. I added a Linksys wireless-G broadband router(WRT54GL) to have wireless in our home. I logged into the Linksys router/wireless and changed the ip address to 192.168.2.1 and set it to the DHCP setting (even though I have a dsl connection) and it worked great.
0
Can you give me a hand with getting my router going? Looks like we had similar problems getting on the internet with AT&Ts DSL and a Linksys Router. Thanks! Hope you can help me!

Steve
0
AHHHHHHHHHHH!!!!!!!!!!!!!!!!! finally! SUCH BS!

Thanks Debb
0
stickykey is right, because I got my fix by calling ATT and they directed me to the same step.

use PPPoE for your att and also configure PPPoE with your linksys router which u must enter the username and password for both things. If anyone is still having problem email me or beter give me ur phone number (u.s numberss). and I can help you more for free.
3
Dear friend:

i have a wrt54 linksys router, and a att dsl conection. I need to configure the router to bridge mode , what can ido to change to this option.

also I have a static IP adress on my service, were can I found the subnet mask address and gateway address and both dns address. People from ATT negver gave me those address. they just gave me the IP address
0
Even after setting the router to PPoE I still see the same problem, so not sure if that is the solution. Another thing is to update the firmware of the router and then reset the router (there is a small hole next to the antennas at the back of the router. Use the tip of a ball point pen or one of those smaller screwdrivers and hold it for 30 secs. Unplug the modem and the router and plug them in after 10 secs and you will have your internet connection up and running
0
kenny bee > maf
Feb 25, 2009 at 05:31 PM
Select Start and select Run. Now type in the word 'cmd'
You will see a new window with black background pop up
Now type 'ipconfig' and hit Enter
You will get your IP address, DNS etc
0
hello. im having the same problem with my att modem and my linksys. please call me at 773-990-0904. thanks. christina
0
i need help with my connection with att and linksys. please help me. I have a connection to access point but no connection to internet.
0
Conncet to your Linksys router to your computer. Set it to automatic Configuration DHCP (it is the default but make sure it is). Look for Local IP address (router IP Address). Change it to 10.10.10.1.

Below that DHCP server, click Enable. STARTING IP adress to 10.10.10.100.

Save Settings.

Click continue.

Go to STATUS TAB. click release IP address. click Renew IP address.


you see DNA server is 198.168.1.254.

Remove compter connection.

Restart Modem, after solid green light, connect router.

Go and check every laptop /computer for wireless connections. At the end, if you have a computer that is to be connected to a router, then connect it to the router using ethernet cable. At any time you want to reset your modem, make sure you are not connected to the computer directly otherwise it changes DNS server and you loose all wireless connections)

I hope it works for you.
3

Didn't find the answer you are looking for?

Ask a question
just an update after 2 days of trying and searching

heres my setup

AT&T DSL
WESTELL modem
Linksys WRT54G

had to go to 192.168.1.1
go to set up screen as mentioned above
basic setup
change local IP to 192.168.2.1
and top drop down bar set to Auto-Config DHCP
and it worked.
3
I had the problem and eventually fixed it similar to what is reported above - by changing the local host address from 192.168.1.1 to 192.168.10.1

Here is what I figure to be the problem. Looks like AT&T is also using NAT gear for its DNS server with the DNS address of 192.168.1.254. When your PC do a DNS look up, it will send the request to AT&T DNS server - with the address of 192.168.1.54. When your default Linksys router got the request, it says "Oh, 192.168.1 is my local network" so the router will not forward the request to the DLS network but will try looking for the DNS server inside your house.

By changing the local network in your house to 192.168.x, where x is not 1, it solves the problem since the router will forward the 192.168.1 packets into the Internet.
1
Why won't AT&T tell anyone this? Does Linksys tell you this if you call their T support? AT&T wanted $30 to tell me that I had to buy another router cause they don't support, know how to tell me to change an internal IP on the router (I was ready to change the router setup when I called them, two hours later I gave up before talking with anyone who really knew anything). An internet search produced two threads with this simple solution of not clashing subnets and I was up and running in 5 minutes.

Thanks for posting.
0
LittleJoeTheMan
Mar 8, 2014 at 12:33 AM
when setting up a router behind router you need to know your isp modem/router ip range before attempting to set up any secondary router.....most all of the AT&T routers use 192.168.1.x
use any other private IP range for your secondary router....172.16.x.x is a good one to use
0
Yes, the answer is to change the IP address of your router, and here's why?

Unlike a cable modem, a DSL modem is a gateway, a pseudo-router in its own right. It has its own IP address and configuration page if you were to type that number into the address bar of a browser. It also typically has a DHCP server so I can assign an IP address to your computer.

The problem with hooking up a router in-line with your DSL connection is that typically a router is also a DHCP server, and its IP address is usually in the exact same subnet as the DSL modem. In my case, the router was at its default 192.168.1.1 and the DSL modem was at 192.168.1.254. Well the DSL modem's address happened to be in the range of assignable addresses for my router, and vice-versa. So basically the situation was two DHCP servers fighting over the same range of addresses. I changed the router's IP address to 10.0.0.1 and all was well, but pretty much any address that wasn't 192.168.1.x would have worked. By putting the router on a different subnet, you basically separate two fighting territorial wolves and give them each their own space to control.

A word to the wise, DO NOT call your DSL technical support. They are not equipped to handle wireless router questions.

Of course the simplest solution is the buy a DSL modem with a built-in wireless gateway in the first place.
1
I work for an ISP that uses PPPoE. I find these threads rather interesting and how complicated people are making things sound. First off, the ISP I work for has several different models of DSL modems. Some of our modems do not do any routing or assigning of DHCP at all they require DSL software on the client side (i.e. your PC such as the PPPoE client built-in to windows or in older versions of Windows a client such as RasPPPoE , enternet 300, or winpoet).

The basic modems would not have the issue with IP conflicts due to DHCP servers built-in to the DSL modem since these modems do not have any firewalls or DHCP servers built-in and cannot connect without external software. We also have a brand of modem that has "router-like" software built-in to it. When these second type of DSL modems are setup to do PPPoE they do have a DHCP Server (which can be turned off by logging into the interface of the modem our modems like most routers have a web based interface that uses a non standard Private IP to connect to it i.e. 192.168.100.254). Turning off the DHCP server on the DSL modem and hard resetting it using the pin hole reset on it causes the modem to act as a standard dsl modem (i.e. it disables the PPPoE authentication and DHCP server on the modem). If you then connect a router to the modem after hard resetting it (pin hole reset), you can then plug a router into it and let the router do the PPPoE authentication and do dhcp instead of the DSL modem.

I suspect AT&T's DSL modems probably can be reset similarly so that they act in "Bridge Mode". Bridge Mode is when your DSL modem does not do the PPPoE authenticating or DHCP functions. Most older DSL modems are bridge mode only and do not have advanced firmware to allow them to do DHCP and PPPoE. Newer DSL modems are capable of doing DHCP and PPPoE.

I suspect the AT&T DSL modems likely have a pin hole reset similar to the ISP I work for and can likely be set into bridge modem using the pin hole reset. If you reset the modem to place it in bridge mode, all this non-sense of changing the IP range should be unnesscassary.

One way you can use to determine the web admin IP of your AT&T DSL modem if it has one, is to hook up the DSL modem directly to one computer via ethernet reboot both your PC and modem to be on the safe side (make sure that the TCP/IP connection of the NIC card you are plugged into on your computer doesn't have any static IP information configured in it) and then drop to a command prompt by going to start->run (possibly may have to go to start->all programs->accessories on Vista) and typing in cmd (may have to run cmd in admin mode on vista which requires right clicking cmd and clicking run as admin) and at the dos prompt type in arp -a and hit enter. The arp command should show the mac addresses and associated IP's of all interfaces connected to your computer including the IP and Mac of the AT&T DSL modem. Write down all IP addresses listed that are in the 192.x.x.x range (i.e. such as 192.168.1.1 192.168.2.1 192.168.100.254 etc) and then launch your web browser and type in http://IPaddress (i.e. if one of the addresses was 192.168.1.1 type in http://192.168.1.1 and hit enter). Repeat these steps if nothing happens with any other 192.x.x.x addresses that were listed when you had typed in the arp -a command. One of the addresses should bring up the AT&T DSL modems logon screen. At that point you would need to know the default admin/password to access it or else you would need to use the pin hole reset on the AT&T modem to wipe out the password and to place the modem in bridge mode.

Of course, since I am not familiar with the model of modems AT&T uses I will not recommend using the pin hole reset as I do not know if AT&T has flashed their modems with firmware and hard coded your user info in it, Its possible that AT&T may not allow you to hard reset their modems I am not familiar with their policies. The modems on the IS{ I work for are usually not hard coded with the DSL userid and password and come with a config CD that users often run. When you run the CD, it actually sets up PPPoE auth on our modems and sets them for "non bridged mode" i.e. a mode that may cause issues with 3rd party routers. If AT&T similarly sends out a cd to configure their modems, I would recommend not using it and configuring your router first to see if it will work without setting up the modem as the modem may default to bridge mode as our modems do.

In any case, you have potentially two or three options. If At&T offers DSL modems that default to bridge mode, opt for one of them as it will make life easier. If the AT&T modems have a reset button, ask AT&T if it is okay to reset the modem with the pin hole reset, if they have no issues with it reset it then setup your router and do not bother changing the IP and see if it works this way (likely it will as the pin hole reset on the DSL modem will likely wipe the settings thus placing the modem in bridge mode therefore the DHCP server will not be active on the dsl modem and will therefore not conflict with your routers dhcp).

The third option is to change the dhcp ranges of your router and dsl modem, There are other options as well but these are the two best options.
0
Hi brstilson,
I had been having problems for 2 weeks reconnecting to the Internet with a new AT&T modem. My old one went out after 3 yrs and I already had a Linksys router for a year. I'm a novice with computer tech, so I went through tech support from Linksys and At&t. Over a 4-day period, both companies kept sending me back and forth to fix the problem. At&t even had the audacity to say they could fix the problem via advanced tech support for $99.00. Thanks to this forum and your advice, I'm now able to get the Internet again. Many, many thanks!
0
I love you dude thank you so so so so so so so so so much!!!
0
$99 is a deal-they wanted $129 to fix mine. Thanks all!
0
I am having a preamble with a t & t support plus maintenance some their keep changing my password an the location of my picture and my file and my document I pay a t &t to keep my computer running smooth a t & t are not doing their job I am now looking for a severe to keep my inter safe and have more etic vauel
0
Even with the setting changed to 192.168.2.1, it connects but will NOT let both a wired in desktop and a wireless Laptop out to the internet at the same time. I am doing this for a friend whose old Siemens modem went out. I am having her return it and get the 2Wire - not worth all the wasted time to keep working on the Motorola modem - which is a piece of junk in any case.

Note - last fall, for reasons I will not get into, I temporally went off Earthlink DSL (on AT&T lines) to AT&T dry loop. Went through hell trying to get the Motorola working with my Dlink draft N router. Got second level AT&T to work with me on this, and they were surprised that after trying a number of settings changes (in addition to the domain number change), it would work briefly and then always go out. Even tried a 2Wire in bridge mode (I needed to stay with N), which also worked briefly that stopped.

I tried plugging in my Earthlink modem (without modifying any settings) and it worked for a few months until I moved. The AT&T tech (I had his direct line by that point) was really surprised also. I was able to return all AT&T devices for full credit.

As a result of all this, there is no way I would go with AT&T as a direct ESP. I actually got good support help (NOT in India), but their proprietary modem mods make their overall service unacceptable.
1
router IP change worked for me... went from 192.168.1.1 to 192.168.10.1
got the ol' internets going again, no PPPoE changes, no speed decrease, and I can access the internet simultaneously from a wireless laptop and this computer

procedure:
1) changed router IP
2) Plugged ethernet into modem
3) unplugged both
4) plugged in modem, waited for all possible lights to come on
5) plugged in router
6) posted this comment

Service: AT&T U-verse DSL 6.0Mb
Modem: Motorola MIPDSLA (standard black one in the AT&T startup box)
Router: Linksys WRT54GS v2
1
First you need to configure att&t modem from PPP to PPPoE. once you configure it, go ahead plug the network cable to the wireless router.
2nd: configure wireless router from DHCP to PPPoE mode.
3rd: enter your full customer ID. Example: joesmith@att.net, don't forget your DSL network password.
4th: just click save settings and you are done.
1
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,833
Dec 22, 2008 at 09:15 PM
Call the Linksys help line - they should be able to help you better than any of us.
0
Connect one computer via wireline to the the router and disable the LAN connection in network places.
Think the problem you're having is that router is confused about whether to open the wireless port or LAN port of the connected device.
0
I'm having the same problem. Did linksys help you and if so what did they suggest?
0
i am also having the same problem with my att router dsl modem from motorola when using the linksys wireless, everything will go well but then it will say "the router was unable to connect to the internet." this is making me very angry.
if anyone knows how to fix this please tell us.
thank you
0
can you give me the exact network setup?

ex. ISP, brand of the modem, linksys device and version, how many computers, etc.


Regards,

John
0
Received AT&T Motorola modem today to replace the one we had for 4 years that had stoppes working. However, after doing all the AT&T modem setup (a ridiculous process) I could tell that the modem worked but only could access the internet when not going through the Lyksys router. Spent the usual 20min on hold w/ tech support and 20min talking to them.... but of course they had no solution (except to imply I hooked something up wrong). Manu hours of frustration until discovering this form. The lynksis ip fix workedsuper smoothly. I was up and running in 5kin. to all the folks who made detailed posts, THANK YOU!! (AND to AT&T.... they can jump in a lake)
0
Okay, So log into your router via 192.168.1.1 in your browsers address bar. Got to basic setup. Then at the top of the page you should have a drop down menu that has a list of ways to connect to the internet. It is my understanding that you need to use PPPoE and the designated account that you have with at&t. Use this and you should be able to connect now.
0
hey im having the same problem with my att modem and my linksys. please call me at Phone number removed for security anytime. thank you. christina
0
campaigner1 Posts 4 Registration date Saturday March 7, 2009 Status Member Last seen March 8, 2009
Mar 8, 2009 at 03:02 PM
I've been having the exact same problem. I purchased a Linksys router just last month, and finally got around to connecting it this weekend. I'm using an ATT DSL modem and my internet connection is fine, no problems. When my DSL modem is connected directly to my computer, my internet works flawlessly.

I went through the setup Wizard CD and go to the point where router was checking my internet connection(step 9 or 10 on the CD Wizard I believe), and after what appears to be three tries it says "router could not find an internet connection".

So I went online to educate myself about the problem, and I discovered that many recommend not using the setup CD. I found tutorials about how to configure it myself blah blah. So I did all that, followed a lengthy tutorial I found online.... powered down properly, powered back up, reconnected, logged onto the Linksys configuration page directly using the router's IP address. I entered all the information, PPPoE, ATT username and password, etc. Got right to the point of checking the status of the connection....and nothing. It will not connect.



It still won't connect.

No idea what to do next. Update firmware? Different router? Maybe a problem with Linksys being used with ATT modems? Any ideas?

Mike
0
I typed in adressbar http://192.168.1.1 and when it asks for username and password admin pass and username don't work any1 knows how do I change it?
0
Hey Flisk,
Leave your username blank and use admin for password. If that doesn't work, you'll need to reset your linksys device. To reset my linksys printer server, I unplug the power, put a pen in the reset hole, then plug the power back in, leaving the pen pushing in the reset button for 10 seconds. Then you should be able to leave the username blank and type admin for the password.
0
If it's a Linksys router leave the username blank and use the password "admin." if this doesn't work, you'll have to restore it to factory settings by pressing the EZ setup button (it's the glowing orange Cisco logo)
0
my internet sucks
Aug 8, 2009 at 01:12 AM
Ok so I changed the local address to 192.168.2.1 and kept the dhcp as is, but now my internet is slower then what it use to be and videos load extra extra slow...And on top of it all, I called At&t dsl line and they said they cant help me with my router. They want me to pay their tech people for their modem resetting!!! Any solutions to get it running back in DSL mode and not 54mps
0
Yes, fixed my problem also I switch from comcast cable modem to ATT DSL modem and All I had to do was change the Ip address of my Linksys wireless router from 192.168.1.1 to 192.168.2.1 and leave the drop down menus to the default automatic DHCP and I was able to connect to the internet..from what I understand DSL uses this address and Comcast cable it doesn`t so thats were the confiict was...Good luck
Steve
0
You are awsome
0
You have to bridge the att modem 1st-then hook up the router and set it to pppoe with yout att provided username and password---if it doesnt immediately work, powercycle the entire network in this order ---modem, router, pc and bring it back up the same way....then you should be able to surf with no problem
0
Changed the local address of the Linksys rtr to 192.168.2.1 and then DCHP automatically changed to start at "192.168.2.100", will this be ok? I am setting up a rtr for my boss that he is going to connect himself, I want everything to work! :)
0
penguin > genesis211
Jan 13, 2010 at 11:45 PM
Changing local address of linksys to 192.168.2.1. However, I have to use "Automatic Configuration - DHCP" in my linksys WRT54G Version 5 to make it works. Mine is AT&T DSL modem(Motorola).

Thanks for the hints from folks in this forum. Finally my wireless router is working and I'm "off leash"..off from the wire... :)
0
hey thanks to the fine chap/s who pointed out that you merely have to change the default dns to 192.168.2.1 as opposed to 1.1 --- I too had at&t basically weasel around and transfer me to three people going through call-screens where they're like "if you want to use our premium tech support service dial this number, it can be billed either to your credit card or account" or press 2 or 3 or whatever.

i get a lady on the phone tell her I just need that one magic little thing to do to make it work, and she asked for credit card numbers so they can charge me $30.

it wouldn't surprise me if they have their modems route like that on purpose so that way schmucks with linksys routers go UH OH and might not have the foresight to google the problem and see what the people say, and then they'll go $30 please and then BAM. you're in. or well someone said linksys says it, but again, it's a rough and tumble world and so it goes, my friends, so it goes.

anyways, now I am not chained to the wall by the incoming phonebox downstairs so I can sit upstairs and wireless route like the pimp I am so thank you guys for all of your help. you do the lord's work here

# james, like lebron,
0
  • 1
  • 2