Can't connect to Google or Yahoo search

brian - Jun 28, 2009 at 01:40 AM
 anon - Feb 7, 2013 at 01:31 PM

I have a very strange problem that I can't figure out. I can not connect to Google or Yahoo search. I can do a search with Bing and Lycos. I can't hit anything on Google or I can hit and and other Yahoo sites (not Yahoo answers though), but when I click "search" on the connection times out. I can get to all other non-yahoo search or google sites I have tried.

I have tried with IE and Firefox. I have also run a spyware program and nothing was found. I have an old Norton definition that finds nothing.

I have a Linksys router and Netgear wireless card. It worked perfectly before, then all of the sudden the search functionality of Yahoo and Google disappeared.

It appears to be virus based since I can get to Bing (new) and Lycos (nobody uses), but I have been unable to find anything b/c a) its weird, and b) I can't get to some sites b/c of the problem.

Has anyone come across something like this before? I am open to trying anything.

Thanks in advance!!

11 responses

I found the resolution. The hosts file (C:\WINDOWS\system32\drivers\etc) was apparently altered by some sort of virus or spyware. The file contained numerous entries, including those that were blocked on my computer. I removed all the entries from the file and all the sites were assessable (taking a backup first, of course)

The corrupt file contained several hundred sites that would have been blocked if I had tried them.
Thanks Brian, that solution worked for my girlfriend's computer as well. She was having exact same symptoms as you described and your fix worked. Very helpful, thank you!
Thanks for this. I had the problem on 2 computers here at work. Your fix worked! Wanted to add that your fix only works if you uninstall SPYWARE TERMINATOR. The problem only occurred on computers that carried that program.
Hey Brian,

I had this same problem today with a customers computer. I am a Verizon Dsl Tech and used HiJack this to scan there computer it found hundreds of blocked files mostly Google. I went to the "run" command typed in notepad "C:\WINDOWS\system32\drivers\etc\host" I was able to remove/edit all the files below the did a "save as" restarted the computer and NO LUCK. I ran the program again the system32\driver\etc file was back to the same with all the same problems. I tried to get our advanced tech support to help, wow that was a mistake they blue screened my customers computer. After 5hrs of recovering there files they are still having the same problem. How did you edit the system32 file?

Thanks Mark
thanks so much brian..that worked...
Thank you so much!! My yahoo and google search is okay already. thank you so so much. :)
I had this problem running apple os leopard. problem traced back to peer guardian, uninstalled peer guardian and problem solved immediately. Don't know if its the same for P.C.s. Hope this helps somebody.


Suddenly unable to connect to any google domains or yahoo.

Apple mac OS snow leopard.
Mac pro.

Uninstall peer guardian.
bernie ramone
Dec 2, 2009 at 12:23 AM
If you have spyware or virus ...remove it.
Never reload your system...thats a losers way to fix things.
bryan007w Posts 12 Registration date Monday June 22, 2009 Status Member Last seen July 13, 2009 2
Jun 28, 2009 at 02:49 AM
Hi, I did have a similar problem some time back. According to my knowledge, this is more of a spyware rather than a virus. (possibilities are that a virus infection maybe downloaded as well via this infection) so before you do any formatting, you have to clear the infection. Try downloading "Super Anti Spyware" and run a full sys scan+ you could download the latest updates for your virus guard or even try AVG as suggested.

Good Luck!
Hi Bryan;

I have the same issue with my computer. I noticed you mentioned removing files from the C: Windows/32 drivers etc. Where do I locate this to delete the files from my computer?


Didn't find the answer you are looking for?

Ask a question
Anshuman Posts 3 Registration date Saturday June 27, 2009 Status Member Last seen June 28, 2009
Jun 28, 2009 at 01:58 AM
I think there might be a virus on ur computer so install AVG with latest updates ...and then try....

or if nothin helps Re install ur windows.
Well I am having the exact same problem. But I used to have 112 different viruses (eg trojan, backdoor, worm, spyware, malware, adware & more) I have tried all those and they don't work. But I highly doubt its a browers hijacker. What I did that worked on everything except google was running a scan and changing my internet settings. Hoped it worked
I was using google messenger for instant messaging and also for voice. For the last three days I cannot log in keeps saying wrong password which is nonsense. Keep getting error message 81003005. I also cant log into my yahoo mail. Anyone know what the problem could be?
I was going crazy with this but finally managed to connect to google again. I updated AVG and ran a Rootkit scan. It found 2 threats and I removed them both. Problem solved.

Hope this helps someone. After almost despairing with good hosts file and no malware found by a few programs, this is what worked for me.
I downloaded AVG b/c my Norton definition was old and required a new subscription (note that the Norton download site is also one that is blocked). AVG found no viruses (it vaulted some cookies, but that is all). I use Malwarebytes for spyware and it finds nothing new when I run it.

I am writing this response from another computer on the same router, so its not router-based.

I downloaded a fix for the Conficker work from Norton:

This was also not found. Having trouble resolving this and don't want to reformat my computer just to clear it. I assume someone else has had the same problem.

Can't connect to:
yahoo answers
some message boards regarding security/viruses/etc, including (this one)!!

Can connect to Yahoo mail, bing, lycos, pretty much everything else I try.
y no try deleting d cookies...
Not in all cases the problem is same like you JEM, these a days people are having problem with a browser hijacker, that sometimes dos,nt let user connect to search engines
Thanks. I solved my problem!