My ACER Aspire 6920G wont load/boot properly. [Solved/Closed]

Chris - Sep 6, 2009 at 12:24 PM - Latest reply:  Vijay
- Nov 1, 2012 at 12:14 PM
Hello,
My ACER Aspire 6920G will not load/boot past the microsoft corporation loading screen. It just keeps loading and loading and I have to turn it off by holding down the power button, when I turn it back on it says 'windows error recovery' and I have the option of either 'launch start up (recommended)' or 'start windows normally' naturally I do the recommended although I have tried the other (still nothing). when I do the launch start up it comes onto a 'startup repair' screen where it attempts to repair it. when it is finished and it restarts my laptop it still does the same thing. I have tried this close to 50 times. Obviously I am sending this frokm a different laptop because I cant get onto my ACER Aspire at all. Somebody please help me! Cheers.
See more 

10 replies

Best answer
34
Thank you
Try ALT+F10 as soon as it starts up. It has got me a bit further by reinstalling the entire system but I am still not having much luck keeping the system stable.

Thank you, chunky 34

Something to say? Add comment

CCM has helped 1676 users this month

Thanks for your help buddy God bless, worked a miracle for me.
wow it works!!!!
Many thanks, this has solved my issue.
9
Thank you
How do I do that, it wont let me do anything anymore. It doesnt even show the start-up repair page anymore. It shows the microsoft corporation loading screen for a minute or 2, then it just stays black???
7
Thank you
I have the same issue, maybe it was a Windows Update? I cant seem to get the safe mode option as well
7
Thank you
Hi,is it possible to have a copy of the recovery disc as my laptop lost its bluray and other functions...thanks.
sharpman 1023 Posts Saturday May 23, 2009Registration dateContributorStatus October 20, 2010 Last seen - Sep 7, 2009 at 01:40 PM
5
Thank you
run a chkdsk /r on your c: drive asap
sharpman 1023 Posts Saturday May 23, 2009Registration dateContributorStatus October 20, 2010 Last seen - Sep 6, 2009 at 03:53 PM
1
Thank you
have you tried to boot up in safe mode?
have you tried to do a system recovery from hard drive/recovery disk
It didn't give me the choice to do any of them. I have now managed to get it on by pure luck as I kept trying but I have no doubt that it will probably keep doing this.