IDE DVD recognized in boot not BIOS,

chewible - Sep 24, 2009 at 02:44 AM
 Bisc8 - Mar 30, 2010 at 08:23 AM
I have just upgraded an old computer with an Asus P5LD2, which has both SATA and IDE onboard. I have 2 HD, both IDE, on same cable and work fine, recognized by BIOS and Windows XP. I have 2 CD IDE drives, neither work in windows, and this is the wierd thing about BIOS: When it boots and detects IDE drives, it finds the CD drive. When it enters BIOS setup, it does not display the CD drives in the IDE list; HOWEVER, it does offer both CD drives in the boot priority list. Wierd.
I have messed with all the jumpers, taking them out and using 1 CD drive, then the other,then both. The data cable worked fine before the new Mobo install. I just cannot figure out why BIOS will not recognize. Any suggestions?

4 replies

dancedhall Posts 3056 Registration date Wednesday May 13, 2009 Status Member Last seen March 12, 2010 656
Sep 24, 2009 at 04:58 AM
hi there,

try to remove the rtc battery

that is to reset it and try again

Well, I forgot to mention I did try to flash the CMOS, and I did. Since that did not work I transfered ASUS Update onto the computer and updated the BIOS to ver 1.903 or something like that. Still no DVD drive in IDE list, but it still appears in boot priority
OK, got it squared away. The side, solitary IDE Primary cable port on the P5LD2 is for slave and master, or just master IDE drives. The two blue ports, labled IDE Primary and Secondary, are for RAID, and can be configured as such through BIOS. I have attempted to attach non-RAID configured drives to these, and was unsuccessful. There may be a way, but I could not configure the two ports to support both IDE hard drives. I have placed both my IDE drives on one cable to the side (solitary) IDE port, and both are recognized as they should through BIOS and Windows. I swapped my IDE DVD drive with a SATA drive, and it is recognized as well and is fully functioning.
Hi there!

I have the same problem. I was flashing my BIOS because my dvd drive didn't read recorded dvds and something went wrong and... ups, my computer restarted and now it doesn't recognize the dvd/cd drive :( I've tried hardware manager, CMOS BIOS and nothing...

I can't even open the drive!

Does anybody have a solution?