DVD drive not reading EXE files

Closed
ChuckNevol - Jan 30, 2010 at 05:07 PM
 1bad911 - Feb 23, 2010 at 01:13 PM
Hello,

I have a Dell XPS One with a built in DVD drive. I am using Vista home premium. I noticed only recently that if I load a new program that requires loading it through the DVD drive, it will open the autorun looking for photos, but doesn't run the setup. I take the same program CD and load it on my Dell laptop and it immediately finds the setup file and starts to run to load the program. Example: TurboTax. If I Explore the files on the disk, it finds folders, but is blind to the setup.exe file and the autorun file.

I tried updating the driver for the DVD drive, but it says that my driver is up to the latest revision and doesn't need updating.

I'm completely flummoxed. Is there a fix? Do I need to replace the DVD drive? On the XPS One it looks like the whole unit has to be disassembled. No easy removal.

Anyone?

3 replies

xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,829
Jan 30, 2010 at 10:37 PM
You need to change the AutoPlay settings to run the exe files.

Go to start - Control Panel - AutoPlay then change the "software and games" setting

Good Luck
0
chucknevol Posts 2 Registration date Friday January 29, 2010 Status Member Last seen January 31, 2010
Jan 31, 2010 at 06:27 AM
Thank for the idea, and I tried changing the toggle from "ask every time" to "install or run program," but no change - still does not see the setup or autoplay files on CD's.

But I would add this hint to the puzzle: this began when I mistakenly loaded a Windows 7 driver CD for a new printer. That CD saw the autoplay setup files and initiated properly. I ended the process when it said it cannot load since I did not have the proper operating system. When I loaded the Vista CD, it did not see the files. It did, however, on another Dell computer with Vista I have. Could the first CD toggled something? I loaded Turbo Tax, and it would not see the set up files, and tried another computer and initiated properly seeing the setup and loading just fine on the other Vista PC.

By the way, I went back and tried loading the Windows 7 driver CD into the DVD player just now and it still initiates properly, immediately finding the setup file and starts with the initiating window, etc. like it should. How could that be? Did I somehow reformat the drive to only work for WIndows 7 when I'm still using Vista operating system??

Amy other ideas?

Thanks
0
chucknevol Posts 2 Registration date Friday January 29, 2010 Status Member Last seen January 31, 2010
Jan 31, 2010 at 11:25 AM
I found another clue: I see a red apple icon on the file folder when I explore the DVD folder content. I have picked up from some of the message boards that when a program has both Vista and Apple exe files, some DVD drives on Vista computers see only the apple folders and do not see the Vista exe files. Still do not have a solution. Others have not seemed to get one yet either even from Microsoft.
0
I have the same problem with Turbo Tax, I even replaced the drive and it did the same thing. I have also upgraded to Windows 7, still does the same, the disk is fine, it works in every other PC. Pulling my hair out.
0