Belkin router keeps losing connection [Solved/Closed]

- - Latest reply:  emanuel - Jun 30, 2010 at 07:42 AM
Hello,
My Belkin N+ router will work fine for a day or two then lose connection to the internet. I have to restart everything for it to come back. Major pain. I have a dell desktop wired to it, my XBOX 360 wired to it, and then my HP laptop wireless to it. I setup the router with my dell desktop which is running windows xp. What is the problem and what can I do?
See more 

8 replies

Best answer
1
Thank you
belik router have life time warrenty .u go to nearest service center

Say "Thank you" 1

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2898 users this month

0
Thank you
I have the same problem with my Belkin N+ (Only when the Xbox tries to connect). Loses its internet connectivity. Hope the phone line change works cuz I cat 5'd it to the modem and yes it did that "lose connection" thing again.
0
Thank you
I bought Belkin N+ last week and have the same problem. Nearly everyday I lose the connection. I know it is not the modem because I can restore the connection by restarting the router and not touching the modem.
Does this router go into a sleep mode? If so, is there an override?
0
Thank you
Im having a problem along those lines. Its strange, my connection is absolutely perfect when there is only one device (PS3, XBOX, PC) active. For example, my dad was playing COD:MW2 on PS3 and had a rubbish connection (i have the same problem with my PC, but its so bad that the connection actually drops for 5 seconds every 2 minutes constantly), but when I turned my PC off, leaving the PS3 the only internet connected device on in the house, he had an amazing connection. I too am using a Belkin Router, and ive also contacted Belkin and had a nice 3 week long chat with them. I got the router replaced, but it made no difference. I think I can safely say that it isnt a problem with your router, but it is a problem with your other devices. They may have the same IP. Ive just changed my IP on my PC prior to typing this, but it has made little difference. Anyway, I hope an answer to your problem will solve my problem.

Ill leave you with a suggestion. Now, this may or may not work, but renewing your IP might solve your problem, but it didnt solve mine. This WILL NOT harm your internet connection, so dont fear it. Here goes.

Ok. Go into "command prompt"
Next, type in "ipconfig", without the speech marks, to view your current IP, DNS, and Gateway key.
Now, type in "ipconfig/release", without the speech marks, to disconnect your computer and "release" the IP from your computer. Wait about a minute, then type "ipconfig/renew" without the speech marks.
You should regain your connection and your IP should be changed. If not, then there is another, slightly longer way of changing your IP.
Please note that im using Vista, so my menus will be different from yours.

Goto "Control panel" then "View network status and tasks" then "View Status on your Wireless network connection. Then hit "Properties" and double click on "Internet Protocol Version 4", or "6" depending on what your IPCONFIG tells you. Now click on "Use the following IP Address" and enter the first 3 sets of numbers (194.243.2.###) outlined in your IPCONFIG. For the last 3 numbers, enter anything between 1 and 225. Next, enter your Gateway key outlined in your IPCONFIG into both "Default Gateway" and "Prefered DNS server". Dont worry about "Subnet Mask" as it will generate its own key. Now click OK at the bottom and close the windows, keeping Command Prompt up. Now type "ipconfig" to verify if your IP has changed. After that, its just a wait to see if the problem persists. I hope this helps you.
0
Thank you
What is your model number? Maybe you can find someone else on the internet with the same problems. Did you try upgrading the firmware to the newest version? When you lose connection, can you still get into the configuration page (192.168.2.1)? If so, check if your settings are correct. If not, try upgrading the firmware or RMA the router.
0
Thank you
the thing is not to have too many things connected to it at the same time
-1
Thank you
Aha, I may have solved this problem for you.

Im assuming you have Virgin Media, and have a Router and a Modem connected to each other.

Well, both Routers and Modems decode signals coming to them from what ever channel that is connected to them. This means that your Router is trying to decode the Modem's already decoded signal, which is impossible. This cause a conflict and forces your Router to disconnect or to dump all of its memory and reset itself.

There is, as far as I can see, only one way around this. Phone Virgin Media and demand a Wireless Router. This wireless router comes free with the 10MB, 20MB and 50MB package, but you may have recieved a small Modem if you joined one of their packages before they were offering free routers. Whats special about this Router is that it has a small chip inside of it which decodes the Virgin Media signal then forwards it to the broadcasting part of the router, which doesnt try to decode the signal, since it knows that it has already been decoded.

Unfortunetly, there is no way to disable the decoding on your current router. Im pretty sure no router available has an option of "Disable Decoding" so youre going to have to make that short phonecall in order to clear up your problem.

I hope this works for you.
Posts
1635
Registration date
Wednesday May 13, 2009
Last seen
October 16, 2010
-3
Thank you
Hi there,

Change the rj11 phone line cable and connect if problem persist then contact your isp as it may be a communication in your line or on their side.

Thanks