Error msg with installing itunes [Solved/Closed]

Report
-
 Ruhi -
Hello,
I keep getting the following message when trying to install the latest version of itunes:
"There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expercted. Contact your support personnel or package vendor."

I have tried many different options but nothing has allowed me to install the latest version. Any help would be appreciated.

thanks

7 replies

I had the same problem and finally, I find this solution on another forum:


Go to add or remove programs in the control panel, on Windows 7, just go to start, control panel, and then uninstall a program. Find Apple Software Update on the list, and click on repair. Once that is done, try to download iTunes again and it should work.
67
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 3790 users have said thank you to us this month

The Windows Installer CleanUp Utility trick worked for me. Remove iTunes first, then QuickTime. Then Install the new QuickTime, followed by the new iTunes.

Worked without a hitch.

Thanks guys!

J
Thanks , your method worked ! I have tried many things to solve this problem but this one worked ! Thank you very much for your information.
get rid of anything made by apple.
i have had a problem to trying to download itunes 8 onto my computer.everytime I down load file it comes up with the following the feature you are trying to use is on a network resource that is unavailable.enter alt path to a folder containing installation package itune.msi in the box below.i have also tried to delete the programe but it wont allow me to do so.i have also turned my avg 8.0 off.please can someone help as I dont know wot else todo.cheers
I have the same problem!!! I can't find my question though, or I would be able to help you, because someone posted an answer on my question about this problem.Can someone help?!
got a new iphone but cant download itunes to access anthing
same problem :(
I tried everything and was unsuccessful until I finally found the solution here https://support.microsoft.com/en-us/help/886549