Sims 2 pets installation problem

Closed
blessy - Nov 6, 2010 at 11:34 AM
 blessy - Nov 6, 2010 at 05:19 PM
Hello,


I'm having a problem with the sims 2 pets expansion pack, which is starting to get really frustrating. I only have that expansion pack and the sims 2, nothing else.

I do have the original copies back at home, but I'm abroad for a few months, forgot to bring the games (typical), really wanted to play it and got the games from rapidshare.
i use a netbook which means no cd/dvd drive (have an external dvd but just didnt feel like burning it all to cds/dvds etc), its all images that I mounted with daemon tools. sims 2 installed just fine and I play it just fine, its the pets expansion pack thats giving me a headache.

i have the dvd version of the sims at home but I downloaded a 4 cd version, a previous release I think?

the pets install fine to 100% and then it says that its going to update the sims 2 game and thats where the problems start.

it asks for the sims 2 CD4. I mount the image with daemon tools but it wont accept it. I tried burning it to a dvd aswell but still no luck. it wont accept it. maybe because the name of the image and the newly burned dvd is named 'Moj dysk' and not what it would be called in, I supose, an US version?
note:the game is in english, its just the name of the images thats weird.
that might not be it though cause I had no problems when I was installing the sims 2.

if anyone has any idea what to do please help because I really want to play it and I have absolutely no idea what to do.

thanks in advance!!

1 reply

Nou_Nours77 Posts 38 Registration date Tuesday December 30, 2008 Status Member Last seen November 6, 2010 15
Nov 6, 2010 at 03:53 PM
Hello, please try checking your system requirements for knowing whether you need to get any device upgraded.
0
the system is fine.
even when I try to update the game before I install the pets EP it asks for CD 4 but doesnt accept the burned dvd or the image mounted with daemon tools
0