CD/DVD ROM NOT WORKING [Solved/Closed]

DUBLONIUS - Jan 4, 2009 at 06:17 PM - Latest reply:  mac
- Jan 5, 2013 at 03:14 AM
Hello,

i have an acer aspire 5100 laptop running vista and for some reason my cd/dvd rom stopped working. It is no longer in the device manager. I tried deleting the upper and lower filters but that did not work, when I put a cd in my drive it lights up and spins but nothing happens so I know power is getting to it. I have booted from a boot disk so the drive itself is working but vista wont recognize it. Any help would be greatly appreciated
See more 

4 replies

Best answer
14
Thank you
This information is excellent but if you get to the point where you can't find the upper and lower filters and you go to your BIOS and that don't help and yet your DVD/CD ROM still physically works but the computer doesn't want to acknowledge it then try this it is FM......Make sure you have a DVD ready..... goto your Control Panel....System.....Device Manager.....place Your DVD in the Driver then Right Click on... Disk Drives....Click.... Scan For Hardware Changes...........It Worked for me when none of these things worked like I said FM....

Thank you, FM 14

Something to say? Add comment

CCM has helped 1702 users this month

great tip! tried it and it worked, thanks!
I had the same problem with my Acer Aspire 7520. Tried it and The Laptop Now sees the Disk drive. Result Thanks for the Info :-)
You Can Try this for help
http://techhelp-pc.us
For Free Support call on :1-855-639-0999