Please Insert the correct CD-ROM [Solved/Closed]

- - Latest reply:  alpha - Apr 7, 2014 at 05:39 AM
Hi everyone
i seriously need help!
i love the sims 2, its the best :)
so I bought the sims 2 deluxe CD.. I installed it, no problem there, but then there were options lke this;
Read-Me
Launch Game (or something along the lines of that)
Quit

so I wanted to play it right? so I clicked LAUNCH. then the logo with the SIMS 2 came up.
then an Error window came up;
Please Insert Correct CD-ROM, select OK, and restart application.
I DID insert the correct CD-ROM. after the installation it said please insert CD 1 to play game.
i did. then that error message came up. so I am REALLY confused because I know that it is the correct CD!
PLEASE HELP ME if there is anyone out there! :) do it for SIMS!
See more 

3 replies

Best answer
Posts
6
Registration date
Friday April 3, 2009
Last seen
June 14, 2009
38
Thank you
hi,
Go into device manager and under IDE controllers, go to properties for the Bus Master (it might be named differently for other chipsets) and click Update Driver.
Install from a list, then select "Don't search. I will choose..." and select the 'Standard Dual-Channel PCI IDE..." and click Next to install it. When done, reboot and try again.

Thank you, guesh1 38

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2574 users this month

i tried it, I found it but it's not working. sigh. is there any ways for me to play the nfs? thanks
im having the same problem I just installed NFS most wanted but it says "Please insert correct CD
Tnx man you have just oppened my eyes! all you need is to download uniblue driver scanner full version (i recommend warez-bb.org) and that program will find all the uninstalled drivers,chipsets...this is for people who don't have installed SM BUS CONTROLLER!!!

tnx again!
-
If it's a copy it won't work
-
You need the original game DVD (NOT a copy/torrent/download) to play
27
Thank you
This is sometimes caused by having a virtual drive. The game seems to try to read from that instead of your physical drive. Try removing any virtual drives and run the program again. (Programs such as DAEMON tools are used to make virtual drives, http://en.wikipedia.org/wiki/Virtual_drive to read more on virtual drives).
8
Thank you
i have removed virtual drive, still the same error :-(