File association fix

[Solved/Closed]
Report
Posts
3
Registration date
Friday January 25, 2013
Status
Member
Last seen
January 25, 2013
-
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
-
Hello,

I have unzipped the dougknox xp_exe_fix and it doe's not seem to do anything after double clicking the registry data. I cannot open any .exe programs because .Link has hijacked everything.
Thanks


2 replies

Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,

Try this 1

Click on the below hyperlink "LNK" and download the file

LNK

This will restore your default shortcut behavior.

Extract it --> Double-click on the Registry File --> Click on "Yes".

Restart your PC.

Good Luck
Posts
3
Registration date
Friday January 25, 2013
Status
Member
Last seen
January 25, 2013

After double clicking on Registry File nothing happens. Shouldn't I be wanting to change from .Link back to .exe?

Thanks ,
char1936
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,
Try this 1
Click on Start --> Run --> Type regedt32.exe and press Enter. "Registry Editor" will be opened.
If you are having a problem in opening the registry editor then
Click on Start --> Run --> Type control folders and press Enter. "Folder Options" will be opened. Click on the "View" tab. Uncheck the check box "Hide extensions for the known file types" and click on OK.
Now search for the file "regedt32.exe". You can find in the location "C:\WINDOWS\system32".
Rename regedt32 to regedt32.com. Just change the extension exe to com and click on "Yes".
Now double-click on the regedt32.com. "Registry Editor" should be opened.
Click on File --> Import --> Select the exe registry file that you have downloaded from the dougknox and click on "Open".
If your having problem with the default shortcut behavior then in the registry editor this time select the LNK registry file.
Good Luck
Posts
3
Registration date
Friday January 25, 2013
Status
Member
Last seen
January 25, 2013

Thank you for your response but,this problem is not solved yet. I searched through the Registry Editor and there is no "regedit32.exe file. There is a "regedit32" file in c:\\windows\regedit32" I did not touch it.

Kind thanks,
cha1936

Unsolved
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,
Try this 1
Copy that rededt32 file to C:\WINDOWS\system32 and follow the instructions. If the problem still exists then make an another copy of regedt32.exe and change the extension to .com as given in the above instructions and then double-click on it and try to import the registry files.
You can also copy the regedt32.exe from an another PC and paste it to your PC
Good Luck

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!