Computer switches on, but not monitor. RAM? Motherboard? PowerS?

Closed
Tenners Posts 3 Registration date Friday February 15, 2013 Status Member Last seen February 16, 2013 - Feb 16, 2013 at 03:09 PM
Ambucias Posts 47360 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 - Feb 17, 2013 at 05:35 AM
Hello, my computer is annoying me. It switches on, from the box or whatever it's called, but the monitor says no signal. I've made sure that everything is plugged in correctedly, too. The kepyboard doesn't have the lights on, nor the mouse as they're plugged in from the computer. after reseaching on the problem, some say I need a new power supply. Is that true? As when I tryied to do the trick "plug it out, hold button for 30 seconds, plug back in" trick, it still doesn't work. Also, when switching on computer, it doesn't make any beeping sound, if that helps.

After reseach on youtube, I've cleaned the RAM & still doesn't work. I've taken both out & it makes a loud beeping sound... I hear that means the motherboard is tell me to put ram back in? Am I right?

Other say its the powersupply, but the fan inside the powersupply is spinning...


Please, help :( if it's the motherboard, where is it located & what do I do?

2 replies

Ambucias Posts 47360 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,253
Feb 16, 2013 at 05:35 PM
Hello

Is this a MAC ? If not, what is your operating system ?
0
Tenners Posts 3 Registration date Friday February 15, 2013 Status Member Last seen February 16, 2013
Feb 16, 2013 at 06:54 PM
It's a packard bell. Not sure what model.
0
Ambucias Posts 47360 Registration date Monday February 1, 2010 Status Moderator Last seen September 1, 2021 11,253
Feb 17, 2013 at 05:35 AM
What is your operating system ?

Have you tried to boot in safe mode ?
0