Screen issues

[Closed]
Report
Posts
3
Registration date
Wednesday April 24, 2013
Status
Member
Last seen
April 25, 2013
-
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
-
Hello out there. I was hoping that someone could help me with an issue im having with my Toshiba Qosmio X500.

Heres the story with what happened. I go to turn on my computer last night to find out that screen isnt working. When i power down, by holding the power button as i cant see the screen to do it through the Start menu, then power back up one of two things happen.

1) toshiba screen comes on then the "Starting Windows" screen. The logo will pulseate like normal but nothing will happen after that. It will shut it self down.
2) there will be no toshiba screen and no windows logo screen but after awhile the familiar windows start noice will chime. I know its working due to when i plug in my external HD or anything else the computer will chime.

Here is what ive tryed:
1) hold F8 for safe mode but i never know if it works because i cant see the screen.
2) F12 to go into the setting thing, lol dont know the name, and turned it all to default.
3) pulled the battery and started it just via the power plug, got to windows logo but nothing after, computer shut itself off

Any help on the matter would be greatly appreciated. Oh and some additional information about my laptop is that it is on usually 24/7.

Thanks in advance for the help.

3 replies

Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
46
Hi Jagwire,

Please try these basic steps and check if this can fix the problem:

1. Connect an external monitor to the Laptop (if available) and check if you get any video. Refer to the Laptop's Manual for steps on how to connect an external Monitor to the laptop.
2. If video is displayed on the external monitor and no video on the notebook LCD, this indicates that the problem is with the LCD assembly.
3. If there is no video on the external monitor also, this indicates the failure is with the graphics chip on the motherboard.

If possible, please take a technician's help and try to re-seat the LCD cable that connects to the motherboard and check as this might cause the problem sometimes. If any of these steps don't work try contacting Acer Support for further assistance.

Please reply if you have any other queries.
Posts
3
Registration date
Wednesday April 24, 2013
Status
Member
Last seen
April 25, 2013

Thank you for the fix ideas. I used an hdmi cable and conected my laptop to my tv and there was still no picture. I am going to a computer repair shop today so i will ask him if he can check that connection.

Thank you for your help with this and i will report back with the status of my poor laptop.
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
46
Hi Jagwire,

I will await your response; this will definitely help other users in the forum. Please do write back to us.