Made it worse [Closed]

Report
Posts
5
Registration date
Friday May 31, 2013
Status
Member
Last seen
June 2, 2013
-
Posts
5
Registration date
Friday May 31, 2013
Status
Member
Last seen
June 2, 2013
-
Just when i thought i couldn't do any more damage.. I put up a post a few minutes ago > When I turn on my Toshiba laptop all is good at first sets up and the user screen comes up with my profile and another one i set up but when i enter my password it says welcome and the icon spins around and then i get a black screen with a white mouse icon. same for the guest profile. My internet security did run out last week but ive only get emails. No 'dangerous' sites.
I have turned t of restarted, took out the battery for 60 seconds etc. I can get into safe mod but the internet wont work in there.
Any help greatly appreciated.< On his website there was a suggestion to take out the ram in case dust.. I id so (VERY carefully)and now it sill turns on but the screen Completely blank from the off. Hard reboot wont work. I know i should have left it alone! Ill bring to a repair shop on Sunday but does it sound like it can be easily fixed?

2 replies

Posts
6491
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,
Try this 1
If you started having the display problem then once again remove the RAM from the slot and this time make sure you have properly placed the RAM back into the slot or try another slot.
When the Display appears then if you are able to boot into "Safe Mode" then you should be able to boot into "Safe Mode with Networking".
Let us know if you are able to boot into it.
Also Let us know your operating system.
Good Luck
Posts
5
Registration date
Friday May 31, 2013
Status
Member
Last seen
June 2, 2013

Hi
Thanks so much for your help bt unfortunatly the laptop wont charge when plugged in so i have no choice but to bring it to a repair place. thanks a lot anyway.