Network Adapter Driver Issues

Closed
traun2445
Posts
1
Registration date
Wednesday June 19, 2013
Status
Member
Last seen
June 19, 2013
- Jun 19, 2013 at 08:14 PM
 traun2445 - Jun 21, 2013 at 07:09 PM
Hello all,

New to the forum and looking for some help.

Today I was on the Internet and it worked fine, tried again and was unable to connect.

I did some basic troubleshooting and it came back that "There might be a problem with the driver for the wiress network adapter". Okay, so I tried to connect directly to the modem and was unable to connect directly, said there was a problem with the driver for the Local Area Connection as well. I found that there are updates available but am unable to connect to the Internet to install them.

Furthermore, It says I cannot connect but them says I am connected with limited access. I am picking up the signal and have a dual band router and my friend and I seperated the two signals for ps3 purposes. We set it to connect automatically to the G signal, which it has always done with no issues. I tried connecting to both signals and neither work.

Any advice would be greatly appreciated. I have not changed any settings and it all of a sudden stopped working. How am I suppose to install updates if I cannot get online. We do have access to a laptop if that could make things any easier. I am going to school online and studying for my A+ certication so I need to get this fixed asap!

Thanks in advace everyone!!

Nathan T

4 replies

xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,829
Jun 20, 2013 at 04:11 PM
You don't need to download a new driver If you had an old driver that worked. You can use the "Roll Back Driver" option to return to the older driver that worked.
You need to go to the "Device Manager" option of the "Control Panel". Select "Network Adapters" and double click on the adapter you want to change. Then select the "Driver" tab and then "Roll Back Driver" in the drop-down menu.
Another option is to download new drivers to a USB drive on a second working computer. Then use the Flash drive to update the drivers on the broken computer.

Good Luck
0
Thanks for the comments!

The roll back option was not even able to click on, it was just gray. It also says my driver is up to date but I am not connected to the Internet and yesterday I found updates for it. Also, when u say install the drivers you mean just the updates right? I wrote down my adapter information and version. How do I go about finding what updates I need?

Thanks!
0
xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,829
Jun 20, 2013 at 07:00 PM
You can do a Google search for for "driver" and you adapter name.
But, I suggest you test your laptop at a public site to see if this is a WiFi problem or not. It's strange that your drivers should stop working without any update. If you had an update then you would be able to roll back.
You might also check you browser security settings - some malware will reset the defaults and/or set it to use a private network - with the result that you can't connect. You might try to reset IE security to the default settings.

Can other laptops connect to your router? You might need to reset it if your PS3 settings have disabled something.
0
Now the ps3 works again, and our phones. Now the only thing that doesn't work is the pc. Seems very odd to me. I gonna search for updates soon, we do have AVG and I run malware bytes and anti spyware pretty regularly. I do run Firefox. But even before I try to open a browser I only connect with limited access. I can even connect directly to modem. Talked to the ISP, they were able to access my router but once they sent a ping and said it did not return correctly. Just so odd that it works then doesn't. Now everything but pc connects...I haven't changed a thing. Worked great yesterday then all of a sudden - nothing.

Thanks much!

Nathan Traurig
0
I also just checked for updates for my driver and it has the most current update. What else can I do?

Thanks!!!

Nathan
0
Okay, I lied. I found and update, got it on my USB drive but when i put it on pc it says needs to connect to Internet to update?? Did I put it on USB wrong??

Thanks again.

Nathan
0
xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,829
Jun 21, 2013 at 06:43 PM
Did you ever test the laptop at Starbucks or the Library?
That lack of ping makes me suspect the Modem. What did the ISP have to say about it. Perhaps you can do a factory reset of the modem and or router. But, that will undo the PS3 mods you made.
0
hello,

I did not test it anywhere else yet. The ISP said he was able to access the modem when I was on the phone with him, but I still think it has to do with Internet. I know people around the area have been having issues too with the same ISP. So I schedules an appointment for a tech to come.

How do I factory reset the modem?

But I am pretty sure it has to do with the modem or the ISP.

Thanks much

Nathan Traurig
0