Screen wont boot up, no wifi light, p

Closed
chloex3 Posts 4 Registration date Thursday April 23, 2015 Status Member Last seen May 24, 2015 - May 9, 2015 at 05:38 AM
Computertech Posts 3569 Registration date Friday February 6, 2015 Status Moderator Last seen July 18, 2016 - May 25, 2015 at 08:32 AM
Hello so my toshiba satellite laptop was finally working again until One night as usual I shut it down( from the menu etc) then I turned it on the next day and the fans werent running until like an hour later, the power light is on as is the button lighted up but the wifi light wont come on num/caps lock buttons dont light up when pressed

There is sound that the fans are running and when I put a CD in you can hear it starting up but then the screen is still off as well as the wifi light

I am getting a new one but I would like to fix this
Related:

1 response

R2D2_WD Posts 3606 Registration date Monday September 1, 2014 Status Member Last seen February 20, 2017   155
May 11, 2015 at 03:24 AM
Chloex3,

I would recommend you to disconnect the power cable and remove the battery. Hold the power button for a few seconds and try to start again. Try connecting to another monitor. I there is no change, I would reset BIOS to defaults by removing the CMOS battery. It is a bit hard to do it on a laptop, but all depends on the model. Check the laptop's manual for some instructions. The CMOS battery should be removed for a few seconds and then placed back in the socket.

Hope this helps
Thank you for your advice sadly it didnt do anything
But thanks anyway :)
0
Computertech Posts 3569 Registration date Friday February 6, 2015 Status Moderator Last seen July 18, 2016 892 > chloex3
May 13, 2015 at 01:53 AM
Hello chloex3,
Did you try to swap your RAM and reseat it again?
0
chloex3 Posts 4 Registration date Thursday April 23, 2015 Status Member Last seen May 24, 2015 > Computertech Posts 3569 Registration date Friday February 6, 2015 Status Moderator Last seen July 18, 2016
May 13, 2015 at 05:23 PM
I took out the ram and then put it back in, yes
0
Computertech Posts 3569 Registration date Friday February 6, 2015 Status Moderator Last seen July 18, 2016 892 > chloex3 Posts 4 Registration date Thursday April 23, 2015 Status Member Last seen May 24, 2015
May 14, 2015 at 12:25 AM
Hello cholex3,
Please try with any external monitor whether you see any display on it..
If there is display then there may be a problem in your monitor otherwise it may be graphic issue...
0
chloex3 Posts 4 Registration date Thursday April 23, 2015 Status Member Last seen May 24, 2015 > Computertech Posts 3569 Registration date Friday February 6, 2015 Status Moderator Last seen July 18, 2016
May 24, 2015 at 10:05 AM
Yes I have tried this, It worked for a while after I did this but then returned to doing the same thing

Thanks for your help anyway :)
0