Keyboard and mouse not working after installing SSD

Closed
Report
Posts
1
Registration date
Saturday July 29, 2017
Status
Member
Last seen
July 29, 2017
-
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
-
Hello,

I recently purchased a pc tower with out a hard drive. Since my laptop was broken (mother board eroded but everything else was working), I took the ssd from the laptop and placed it in the pc tower. The pc is working fine and the keyboard and mouse works in the bios, but after window logo loads, the keyboard and mouse don't work anymore.

Things I've tried/noticed:

1. Used all usb ports
2. USB Legacy Support is enabled
3. bios recognized keyboard and mouse
4. Keyboard and mouse and the usb ports on the pc works fine


1tb ssd was used in a dell inspiron 15r running win 7

pc tower specs:

CPU: Core i5-4460 @ 3.20GHz
Mobo: MSI H81M - P33
RAM: 2x 2GB PC3-8500 DDR3 1066MHz
GPU: 650Ti BOOST 2GB DDR5
PSU: APS - 450CCP 450W (Stock)

My guess is that the ssd was running on a laptop using the keyboard that was attached to the motherboard (of the laptop), and the config carried over to the new pc tower after it was attached?


Thanks for your help!

1 reply

Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,966
Microsoft will tell you that you do not have a valid Win 7 license. The copy of Win 7 was valid only on the hardware it came on.

It appears that you will need to buy a new copy of Win 10 and install it on a fresh drive. After Win 10 is installed then you can then install the SSD to recover your files.

Good Luck
0