HP 8300 won't start up, 4 beeps and 4 red lights observed. [Closed]

Dhonzzz - Oct 19, 2016 at 04:36 AM - Latest reply: Dhonzzz 3 Posts Wednesday October 19, 2016Registration date October 19, 2016 Last seen
- Oct 19, 2016 at 05:24 AM
Hello,

I had a problem with my HP desktop. When I plug in the AC cord, I already hear beeps and red light flashing. And when I tried to power it on, nothing happened (no fan turning) so I believed it was a power supply issue. But when I replaced with a new PSU, same error occurred.

PLEASE HELP !!!!!..
See more 

5 replies

Ambucias 49775 Posts Monday February 1, 2010Registration dateModeratorStatus February 25, 2018 Last seen - Oct 19, 2016 at 04:46 AM
+1
Helpful
1
Hello

You are correct ! It is a power supply issue and it needs to be replaced.
Was this answer helpful?  
Dhonzzz 3 Posts Wednesday October 19, 2016Registration date October 19, 2016 Last seen - Oct 19, 2016 at 04:59 AM
I already replaced it with a new PSU but problem still persist. I also tried resetting the RAM by removing it on the slot. But same issue happened.
Ambucias 49775 Posts Monday February 1, 2010Registration dateModeratorStatus February 25, 2018 Last seen - Oct 19, 2016 at 05:12 AM
+1
Helpful
1
I'm sorry I meant a motherboard failure. I suggest you consult a repair shop.
Was this answer helpful?  
Dhonzzz 3 Posts Wednesday October 19, 2016Registration date October 19, 2016 Last seen - Oct 19, 2016 at 05:24 AM
Oh NO!!!
Dhonzzz 3 Posts Wednesday October 19, 2016Registration date October 19, 2016 Last seen - Oct 19, 2016 at 05:22 AM
0
Helpful
Now I disconnected almost all connectors on my motherboard. What is left connected were wires from new PSU, internal speaker (to hear the beeps), processor heat sink fan, memory RAM and power button/LED connector. But same result.. 4 beeps and red light flashing... Even without pressing the power on button!!