Xfinity won't load pages

- - Latest reply: ac3mark
Posts
12974
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
September 10, 2019
- Aug 29, 2019 at 01:16 PM
Hello,
I have had this problem for a few months now. I have 150 Mbps for my internet service and it works well enough for what I do, but I have found that there are many websites that give me an error saying the website has timed out or cannot connect to website. These websites include job application websites and my military websites. I've had a technician to my home to try and resolve the issue and they said my computer was the issue but I took my computer to a public WiFi connection and had no issue connecting. Is the problem that I have too slow internet to properly run these websites or is it Xfinity it self?



System Configuration: Android / Chrome 76.0.3809.132
See more 

1 reply

Posts
51344
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 5, 2019
12191
0
Thank you
Hi

150 Mbps allows for 17.88 MB/second download, it's high speed so it's not your internet connection.

What are your computer's specs?
ac3mark
Posts
12974
Registration date
Monday June 3, 2013
Status
Moderator
Last seen
September 10, 2019
1366 -
If I may...clear your dns cache with ipconfig /flushdns from an elevated command prompt.

Then go to speedguide.net, and on the left hand side you will see tcip optimizer. Download it and run it as administrator.

Now open a browser and go to speedtest.com and perform a speedtest. Once that is done, go back to the optimozer and in the middle of the page, there is a slider. Slide the slider to the number that the speedtest said you had. Click optimize all. Restart. Now your pc is configured for your massive pipeline of 150Mbps.
Respond to Ambucias