Shift keys

Report
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020
-
HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020
-
Hello,

After some research of solutions for my two shift keys (left and right) which no longer both work on my laptop, I turn to this forum.
It is not a hardware problem, but probably a shortcut that I had to do without wanting to.
I have to go through the shift lock key for just a capital letter at the start of a sentence, for punctuation, etc ... But also for shortcuts on third party software (photshop, etc ...)
I tried the solution to modify the lock choice in the language options but it did not work ...

Hoping someone has the solution,

Thank you.


Bonjour,

Après quelques recherches de solutions pour mes deux touches shift (gauche et droite) qui ne fonctionnent plus toutes les deux sur mon portable, je me tourne vers ce forum.
Ce n'est pas un problème matériel, mais probablement un raccourci que j'ai dû faire sans le vouloir.
Je dois passer par la touche de verrouillage Maj pour juste une majuscule au début d'une phrase, pour la ponctuation, etc ... Mais aussi pour les raccourcis sur les logiciels tiers (photshop, etc ...)
J'ai essayé la solution pour modifier le choix de verrouillage dans les options de langue mais cela n'a pas fonctionné ...

En espérant que quelqu'un a la solution,

Je vous remercie.

1 reply

Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020
536
Hi,

If you are using Windows 10, open Settings, go to Ease of Access and select Keyboard. Then disable the Use Sticky Keys option if it is enabled.

If the problem persists, reinstall the keyboard driver. Press the Windows + R keys and type
devmgmt.msc
. Right-click on your keyboard driver and select Uninstall device. Once uninstalled, restart your computer.
1
Thank you

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 4405 users have said thank you to us this month

HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020
536 > Od-ray
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020

Use the Windows troubleshooter. Go to Settings > Update & Security > Troubleshoot > Keyboard, and select Run the troubleshooter.

If the troubleshooter didn't fix the issue, check if Windows is up to date from Windows Update and install all the available updates.

Try updating your keyboard driver. In the Device Manager, right-click on the Keyboard driver and select Update driver > Search automatically for updated driver software. You can also try using a third party program such as Driver Booster.
Od-ray
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020
> HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020

Hi again,

All is update (Windows and drivers), and the troubleshooter didn’t find any issues.
And it’s still not fixed..

Thanks for your help, again.
HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020
536 > Od-ray
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020

Open the Control Panel and navigate to Ease of Access > Ease of Access Center > Make the keyboard easier to use.

Next, disable all of the following options:
  • Turn on Mouse Keys
  • Turn on Sticky Keys
  • Turn on Toggle Keys
  • Turn on Filter Keys


Click on Apply to save the changes. If they are currently disabled, enable the options, save the changes, and then disable them again.

If this doesn't work, in Control Panel, go to Region and Language, select the Keyboards and Languages tab and click on Change keyboards. In the General tab, set your default input language as well as your default keyboard (click on Add if the appropriate keyboard isn't in the list) , and remove the additional keyboards.
Od-ray
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020
> HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020

Hi,

I only have the Formats and Administrative tab, I don’t know why the Keyboards and Languages tab isn’t in. But it might be the solution, I guess !
HelpiOS
Posts
7652
Registration date
Friday October 30, 2015
Status
Contributor
Last seen
February 8, 2020
536 > Od-ray
Posts
4
Registration date
Tuesday January 21, 2020
Status
Member
Last seen
February 1, 2020

In Settings, click on Time & Language and go to Language. Select your default language from the list. Next, click on Options.

Under Keyboards, click on Add a keyboard to choose your default keyboard, then delete the other keyboards by selecting them and clicking Remove.