Samsung Galaxy M31 Issue.

Report
Posts
290
Registration date
Friday May 15, 2015
Status
Member
Last seen
May 21, 2021
-
Posts
290
Registration date
Friday May 15, 2015
Status
Member
Last seen
May 21, 2021
-
Hello,

I have a Samsung Galaxy M31 Android 11 (ONE UI 3.0). When I open the Wi-Fi settings to see the available access points near me, it doesn't show them all, it only shows me the strong ones. Why?
And In the Wi-Fi Analyzer app ( https://play.google.com/store/apps/details?id=com.vrem.wifianalyzer ), I can see all the available access points, but not on the phone Wi-Fi settings.
PS: I let it scan for many minutes.

Screenshot from phone's settings.


Screenshot from Wi-Fi Analyzer.

4 replies

Posts
9705
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
May 21, 2021
1,167
Hi,

It seems that your phone is ignoring WiFi points that have a weak signal. I suggest you try with a different device, like your computer or another phone, to see if the WiFi points detected by the application are found or not in their WiFi settings.

If they're detected by your other devices, first of all restart your Samsung phone. Try disabling Secure WiFi by going to Settings > Apps > Secure WiFi. As it can't be disabled because the option is grayed out, select Storage and choose Clear cache and Clear data.

Try also disabling Nearby device scanning from Settings > Connections > More connections settings.

In case the issue persists, check if your phone is up to date and try resetting its network settings. To do so, go to Settings > General management > Reset > Reset network settings.

Good luck
Posts
290
Registration date
Friday May 15, 2015
Status
Member
Last seen
May 21, 2021
2
Hi, thanks for the reply.

About the first option, I didn't find the Secure Wi-Fi in Apps. Then I disabled the Nearby device scanning option, and still nothing happened. After that, I reset the network settings but the problem persists.
I hope you have another solution. If not, I have to accept this and move on.

Thank you again and have a nice day.
Posts
9705
Registration date
Friday October 30, 2015
Status
Moderator
Last seen
May 21, 2021
1,167
You're welcome!

Try disabling certain advanced options for the WiFi connections. In Settings, go to Connections > WiFi > 3 vertical dots > Advanced. Then disable:
  • Switch to mobile data
  • Turn on WiFi automatically
  • WiFi power saving mode


If that doesn't change the WiFi detection, boot your phone in Safe Mode to run only the operating system with its system apps. Third-party apps will be disabled. Thanks to Safe Mode, you'll be able to check whether an app that you downloaded is interfering with the phone's system or not.

To boot in Safe Mode,
  • Power off your Samsung phone,
  • Press and hold the Power and the Volume Down buttons at the same time,
  • When the Samsung logo appears, release the Power button,
  • Keep holding the Volume Down button.


Now in Safe Mode, let your phone scan for new access points. To exit Safe Mode, you simply need to restart your phone.

If the WiFi points that have a weak signal still won't appears in the WiFi settings, you can try to factory reset your phone as a last resort... but it may be designed by the manufacturer that only strong network connections can be used to connect.
Posts
290
Registration date
Friday May 15, 2015
Status
Member
Last seen
May 21, 2021
2
Hi, Thank you for the reply.

Unfortunately, I think that the manufacturer did it on purpose (I don't know why). I've tried all you solutions but without consequences.

Thank you again.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!