Easy pc connects but I cant browse

[Closed]
Report
-
 Alan -
Hello,
after recieving the new easy pc e700 series netbook I tried connecting to our wireless internet and it will let me connect but when i try to open up internet explorer I get a server not found DNS error page instead. I am stumped on this about 5 of us have tried to fix the problem but could not if there is anyone that could help I would greatly appreciate it

Thank you

2 replies

I just got one and fumbled with it for a few minutes. You need to click on the "WiFi Power" icon to get it started then open the wireless connections to pick or create a new one.
6
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

hi,
I have same problem with my netbook . Even after turning on wifi power icon. But the strange thing is it's picking up some connection and in status showing connected but when i open a internet browser it's still showing same massage 'cannot find server or DNS error'. If some body can sort it out please .

Thank you
I just got one too, and I have been stressing about it. I bought actually for the internet and I cant connect, dont know what to do?
I had a similar problem where the Wifi seemed to go into a powersave mode and stop working properly even though it showed networks it couldn't connect to them. Simply running WifiPower and turning it OFF and then ON again fixed the problem.