Flash drive problem

Closed
Jamis - Feb 5, 2010 at 01:06 AM
 Jamis - Feb 5, 2010 at 10:05 AM
Hello,

Problem:
I can't use my flash drive. It's 4GB, but it doesn't show it's size in My Computer, and says 0 bytes in it's Properties window.

Problem Started:
My problem stems from my motherboard's desire to set my new flash drive as the primary boot device every time I plug it in when the computer is off (even after I set a password for my BIOS menu, it would still change it without notifying me or anything). When I turn it on, it tries to boot from it, it doesn't find anything, tells me so, and then asks me to restart. So I restart, go into BIOS, change the settings back, restart, and all is good (just terribly annoying). I never had this problem with my old 256MB flash drive.

One day it did it again. I restarted, changed the BIOS, restart, and when I got to Windows, it says my flash drive is empty - 4GB of nothing. I tried a number of file recovery programs with limited results (I was able to retrieve some of the data). I put the drive away after a while, hoping one day I might find a miracle program that might restore all my files.

Months had past and I had forgotten about the drive until a few days ago when I found it rummaging through a backpack. I couldn't remember what was on the drive anymore, figured it must not be that important, and went to format it and get my 4GB back. I plugged it, went to my computer, right click -> Format...

Nothing. I click it again. Again, nothing. Go to Properties, it says the drive has 0 bytes.

What I've Tried:
I searched Google for a little over an hour with no luck (that's how I found this site). I tried using the HP USB Disk Storage Format Tool, using Window's Disk Management, plugging it into different computers (didn't work), plugging it into different USB ports (didn't work), plugging in different flash drives (they work), and renaming the flash drive it's self, all to no avail.

One interesting thing - I can't rename the drive from the Properties tab (I can't even type in the box), but I can rename it by clicking twice on the drive name in My Computer (but that name doesn't show up in the Properties tab).

Notes:
- I haven't run into a message asking me to insert a disk (as if the flash drive were a CD drive) that some of the other people who's flash drive had also failed them were experiencing.
- I can double click on the drive in My Computer and view the folder, but I can't drop any files to it - I get the message "Cannot copy [file name]: Cannot find the specified file. Make sure you specify the correct path and file name."

1 reply

Blocked Profile
Feb 5, 2010 at 02:17 AM
Dear Sir,

Please have the solution to the problem from the below Kioskea FAQ article:

https://ccm.net/faq/

Thanks in advance.
0
I tried that already. It doesn't show up in the "Disk Management" or the "Removable Storage" sections, even though it shows up in My Computer. It also shows up when I click the "Safely Remove Hardware" system tray icon (it shows up as USB Mass Storage Device, just like normal).
0
Okay, I removed the device and plugged it back in with the Computer Management window open and I got it to show up in "Disk Management", but I can't do anything with it. It doesn't show up in the top section, but in the bottom section it shows up as:

Disk 2
Removable (F:)

Unreadable

I tried right-clicking on it, but I can't get a context menu that says delete partition or anything. It also showed up in "Removable Storage" under "Libraries" with my CD drives, but it has an 'x' on it's icon.
0