Can't get time clock stopped off computer

chris - Updated on Apr 11, 2017 at 04:10 AM
 Obwaya - Apr 11, 2017 at 12:28 AM
i just got a dell 1525 inspiron from a friend. Every time I turn it on it says "time of day clock stopped" and will not change screens anybody have any ideas?

14 responses

More info on solving problem: My daughter's laptop (Dell inspiron 1525) had the same issue displaying "time-of-day clock stopped" and I couldn't get it to do anything else including booting from the CD drive. Since she damaged the case by dropping it so the screen/lid can no longer close and I can't ship it out for service (cost to fix lid not worth it) I decided on opening the case myself and replace the battery. I did it and is currently working again. On first boot up I had to go into setup (F2) and reset the clock. Below is a summary of what I did.
There are some plastic "hook tabs" that hold together the case (I broke a few) after the screws are removed. The battery (CR 2032) is located on the motherboard under the left click mouse button. Here are a few screw locations, probably not all because I am writing this after fix and my memory doesn't always serve.
8 screws that hold on funny shape bottom cover.
1 screw in center of opened funny shape cover.
5 screws that hold in a heat dissipater (block of fins and copper flat tube).
2 screws under removable battery. These screws hold on the narrow cover snap lid where power button is located.
2 screws under narrow cover that hold the keyboard in place with remaining snaps.
2 screws under keyboard.
2 screws the hold in the hard drive.
10 screws on bottom of case. I was never able to totally separate the top case from the bottom case but was able to spread front section of cases enough to replace battery.
Very small phillips screw driver.
small regular screw driver.
right angle pick.
small needle nose pliers.
Remember, I had nothing to lose and was accepting the fact that the laptop was a total lost. So you might want to send yours in for professional service.
mark ur a genious !!!! it worked!! thank you so much. the battery was right under the left touch pad botom! took it out for like 10 secs and put it back it and it worked!!!!!!!!! thank you so much dude!
Hi Mark
Thanks for the very informative information. The only problem I had was getting the Keyboard connection loose. I tried lifting the tab with a small screwdriver while pulling up on the cable and the end broke on the flat little piece of #$##$*& connector. I do not know where to get one of these. The cable and MB connector is fine it is just the lttle thin flat piece that is supposed to rocker up.
Anybody know how to get one of these.

The computer now works and I updated the Bios immediatley in case this would fix the problem. I used a USB keyboard to get it up and working. I was upset to see how easy it would have been to make a door for this in the case bottom. There is also a small button I am assuming is a Bios reset in the front of the battery about 1/2 inch left of the Headphone jack. Why didn't they put a pinhole here to help with reseting the Bios.

I replaced the battery and it works. I work on desktops day in and day out and have never had to replace a battery. For this problem to happen indicates the poor quality of the Dell products. I tell every one who asks my advice to buy a HP.

Absolutely quality advice, worked a treat. I unplugged my lady's laptop and forgot to plug it back in, so the battery wore down and she got the now dreaded "time-of-day clock stopped" message when she tried to start up again.
I don't know much about the inside of computers but your advice was great. My main problem was finding the battery as its on the underside of the circuit board, and took some persuading to get out.

heii I just had the same problem with my dell works now thanks to the cr2032 battery change ;)
Replaced the battery on mine, twice now, and was able to fire it up but it is not keeping proper time and has once reverted back to the error message. Any thoughts? Thanks!
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,827
Oct 11, 2008 at 06:58 PM
The Bios battery is probably dead. It is installed on the mother board - on a laptop you will have to take the case apart to get to the battery. Take it to a professional - it might cost $50 - doing it yourself might break the PC .

There is a small button type battery that powers the BIOS and CMOS chips on the motherboard. This is what keeps time when you have the computer turned off.
An additional step to remember -

After removing power chord and main battery, open the laptop and remove CMOS coin cell. At this point, press the power laptops power button and keep it pressed for over 1 mintue. Then install a good CMOS coin cell. Mount main battery and power supply cord.

The laptop would start functioning. It would ask you to setup time and date on first start. Thereafter, it would be as good as new!!!!

Good luck!

I had the same problem. changed the battery, but the date and clock keeps loosing time. Anyone else still have a problem after changing the battery?

Didn't find the answer you are looking for?

Ask a question
Hi. I have had this problem a few times, and with the help of Dell figured it out.
1. Remove the battery from your computer, but leave the power cord plugged in.
2. Hold the power button for 10-15 seconds. The computer may try to turn on, but will power right back down as you are holding the button.
3. Replace the battery, leave the power cord in, and then turn the computer back on.

It worked for me, hope it helps you!
Heh... A customer of mine had this problem... I had to replace the battery and it fixed it. Let's hope it sticks.
I'm not really good in English, especialli writting, so I just use short sentences, OK?
My Dell laptop got the same problem with you and I really worry ablout that, but I found the way to solve that stuff.
I took my laptop to the Dell Distributor in Viet Nam. It's FPT Center. They also have the Servicing Center.

The warrantor checked my laptop. He turned it around. He used a screwdriver to open it. Immediately I could see the BIOS battery, it's round and easy to pick up. He picked it away to check it, after 5 minutes he returned a told me that the BIOS battery is still good, no problem with it.

This is interesting. After that I asked him about the problem "Time-of-day clok stopped". He told me that: "That's because you always take the laptop battery out when you use it (I mean the LAPTOP BATTERY, long, hard.. and you must lnow that :P), and your laptop need the power from your pin to help it supply the energy fot the BIOS". You know, he was right. I always unplug my Laptop Battery and use the power supply (throw a cable which used to charge the laptop Battery when it's empty) because I just don't want to use the laptop battery too much (it's more convenient when I use the power suppy directly because I don't need to charge the battery when it's out of energy :D).
That guy put the BIOS battery in it right position again. Turn my laptop on, and it's working :D
Thanks you! ThreeTails for your post, that's a good information. This laptop that I am working on is also from a young lady an international student from viet nam. It's just pass one year and this laptop is giving her problem with "time clock stopped issue". I have not seen this before, normal when you replaced the cmos battery, it's should takes care the problem just like on the Deskop PC. She didn't give me her AC power supply I could't check that. OH I call Dell, they want to get her full name and where she got it from before they can answer any question, Service Tage # it's not enough. I took this laptop apart so many times that I remember by heart. You are right when remove CMOS batter and put it back in, the system boot to windows Vista. I may need to update CMOS firmware may be that help as well. Thank for all the post and keep it coming.
Sexxii Be@st #1
Mar 25, 2010 at 04:39 PM
i have the exact same problem!!! thanx
xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,827
Nov 20, 2008 at 05:47 PM
you can pull the hard drive - use an adapter to connect it to another PC and copy your data to the 2nd PC's hard drive or burn DVD's with the data.
Did changing the CMOS battery help your laptop. I also have a Dell 1525, and it says, "Time-of-Day clock stopped. My brother n law is changing the CMOS battery, I just wondered if it helped yours?
Joedmti Posts 1 Registration date Saturday February 21, 2009 Status Member Last seen February 22, 2009
Feb 22, 2009 at 01:15 PM
Dell came to my home and replaced the fix. They swapped the fix.
I am now boxing it up ansd sending back to depot for repair............Dell replaced the motherboard 2 months ago for an unrelated problem. This laptop is less than 8 months old! This is not happy! 8-(
Based on Mark's information. I tapped hard on the left mouse button and the computer started up. I had tried everything else and kept getting the time-of-day clock stopped error. Tapping the button worked, or it was just a coincidence.

regarding this problem I suggest caution because it's not said that everything is solved at the first time.
I had the same problem with a Dell XPS 1530 in April, I went to some technicians, and they replaced the battery of the clock (the CMOS battery I think, but not sure).
Computer started working normally again, until last week, when the time-of-day-clock-stopped message appeared again.
The technician told me that some motherboards have some electrical tension defect that it's not dangerous but annoying enough to shorten significantly the life of the clock battery.
just flash the BIOS. install the upgrade A15, instead of the on thats already there the A12
How do I flash the BIOS when the laptop doesn't even boot up?

I have a DELL XPS m1330, just over 2 years old. First, there were time problems on VISTA - the clock kept on falling behind. Then one day it stopped booting. During startup it displays the "Time-of-day clock stopped message". I am not even able to get into the BIOS setup. I got a replacement CMOS battery and it makes no difference to the problem.
have you figured out the cause of this problem yet? I have a dell inspiron 1525 or something-rather and it will be two years old in june, my clock has been off for almost a year. I will change the date, month, time, region and within two hours the clock is significantly off. this afternoon I got the time of day clock stopped message three times and have ceased interest in using the power button to turn off the computer. just curious if you have solved this, my friend suggested the battery but I see that no one here is really having much success with that.
praveen > marley
Mar 10, 2010 at 11:19 AM
If the time is not changing.. you need to synchronize the time with Internet. If that doesnt help try changing the CMOS battery.. It will be resolved in 90% of the cases.. If that still doesnt resolve the problem.. has to change the motherboard as well.. Even after changing the motherboard if the time still doesnt work .. then we need to think as a complex issue.
pls reset ur bios battery
Mekon1 Posts 1 Registration date Sunday August 10, 2014 Status Member Last seen August 10, 2014
Aug 10, 2014 at 09:59 AM
Regarding the "Time of Day clock stopped" 'fault'. Every domestic laptop and desktop computer has a CMOS battery to keep the time ticking over while the computer is switched off. The power that it uses is extremely low but finite. It is not a fault when the power of this battery runs down and the computer loses its clock. It generally means that the CMOS battery needs changing. This can take several years before it becomes necessary and some computers never need it at all. Any repairer who even thinks of changing the mobo for you before he's even tried the CMOS battery is looking for a quick buck. The motherboard CAN be at fault but the CMOS battery should be tried first always as it generally that that needs attention. It is NOT a fault to have it become discharged at ythe end of its life. If that doesn't work THEN consider the mobo etc.