D-Link 524 [Solved/Closed]

- Jan 14, 2008 at 04:32 AM - Latest reply:  gopher
- Aug 22, 2010 at 02:52 PM
Hello,

I have a D-Link 524 (DI-524).

I have Centrino laptop and every now and then my laptop (especially if there is no activity) will get disconnected and connect back, and after I enable WAP-PSK instead of WEP, it's doing that every 1-2 minutes.

Oh, and I’m also getting:

"Windows was unable to find a certificate to log you to the network".

I understand this is not D-Link related; it’s something else, but still D-link getting worse.

Any advice?
See more 

29 replies

Best answer
37
Thank you
Yeap! D-link has probably nothing to do with it.
Maybe, the machine is XP and is seeking out other networks trying to connect to them due to the Wireless Zero Config Service and no preferred network being set...

Thank you, BossOnLine 37

Something to say? Add comment

CCM has helped 1631 users this month

11
Thank you
Hey All,

This is usually because windows remembers a different connection or encryption protocol with the same name...when you try to connect to the network it remembers the old connection and tries to auto-log you into it...gets it all nutted up. Go into the advanced settings of your wireless connection, select Wireless Networks, and remove the old one...this will wash it's brain of the old one and let you enter the new key for the new connection/protocol/whatever.

Benno
Benno!!! I could kiss you!!! I have had nothing but trouble with this for over a year and just tonight spent hours... until I came across your blog. 2 minutes and over a years worth of aggravation GONE!!!! THANK YOU!!!!
Very glad i could help! I spent a while discovering this for myself and it pleases me greatly that I could save others that frustration. Thanks for the comments!

Benno
hi hi

i'm trying to set up my old di 524 but dont have the disk
i found the link on d link but i messed it yup and restored it now it doesnt work at all any ideas

thanks a bunch miranda :)
A friend of mine is having the same problem and tried your solution with no effect. I am going over later to see if I can fix it, but I am wondering if there is anythoing else you recommend trying. We obtained the latest driver and completely removed and reinstalled the card. BTW, this is a new fresh install of WinXP Pro with AFIK, all the latest updates as of four months ago... that's right, he hasn't had internet on this computer for FOUR MONTHS!!!

TIA.

Ken [eGad]
Posts
1
Registration date
Sunday August 2, 2009
Last seen
August 3, 2009
- Aug 3, 2009 at 10:23 AM
Hi there. I did this but it didn't work. If I add in the wep key, it doesn't save it?! What can I try next?
9
Thank you
I had the same issue, but managed to fix it by going to the authentication tab in my wireless network properties and unchecking the "enable IEEE 802.1x authentication" box.
Stimpy!!! This did the trick for me thank you!!!!
Worked for me too!!!!!
This worked for me, thank you so much! Thought my router had finally given up on me and it was time to get a new one ...
This worked for me, Thanks so much
This also worked for me. Thanks a bunch. Hope D-Link publishes this in the future.
Posts
1
Registration date
Friday October 9, 2009
Last seen
October 9, 2009
- Oct 9, 2009 at 10:13 PM
3
Thank you
Remember when u going to set passwords for wireless with DLink router you have to use Internet Explorer if you use another Internet Browser it's not gonna work when you click Apply or OK....!!! Remember that.....!!!
- Paulz
Hi,

I've the 'windows was unable to find a certificate' message with my new D-link router.

it's on WEP security but windows won't even let me click OK when I enter the password(which I know to be correect) as it apparebtly does not have the correct characters.

My SSID comes up in the list, however it doesn't ask for security code when I click to log on, despite the router having one (I set it), the computer simply tries to log on then give the 'windows was unable to find a certificate' message.

The whoole thing is baffling. I have uncheck the EAP box. Removed all networks from my chosen list (about 10 times), reinstalled inet explorer to make sure these options are actually being applied ( I'm a Google chrome user) but none of the above has worked.

I have perfect reception for the network and it works fine for all my housemate computers.

Can somebody help me please!!!
Olly,

When I have a router using WEP encryption (which, by the way is considered very weak protection these days...I'd upgrade to WPA if your router is capable, which it should be as long as you didn't buy it at a garage sale), it accepts a shorter ASCII "passphrase" as a key, but then it uses that passphrase in an algorythm to generate your actual key, which is a 26-digit Hexidecimal key (with a 128-bit WEP encryption protocol). When you use WPA on the other hand, you seem to be able to pick a shorter ASCII phrase that ends up also being the key you enter as the security key in Windows. It probably isn't letting you hit the enter button after typing the password you entered in the router because it doesn't have enough digits to match the length required for the protocol and strength of the network. I'd go to a computer that IS on the network, log into the router and access the screen where the various generated keys are, and write down the first generated key. Enter this key as your authentication password for the network and you should be good to go. I then put that key into a text file on a flash drive in case visitors come over and want into your network...you can give them that and have them copy and paste the key to save you from having to memorize or read out 26 digits.

Or you could start using WPA encryption, which weems to work fine with whatever key you supply, at least in my experience.

Good Luck,

Benno
1
Thank you
Audi -

Did you name your wireless newtwork on the new router a new name or the same name as the old network? Another way to fix this (and arguably just as easy) would be to simply name your new network something different than the SSID the old one had. If that doesn't do it, or if you had already chosen a new name for the new network, verify the error you're getting and we'll see what we can do.

Thanks,

Benno
i got a question on the di 524
i try putting a wireless password but when i save it
it wont apply.
i tried restarting it but nothing, i change the name but without a password
it saves like nothing
and with a password it wont apply
any ideas that would help me
thanks
i'm having the same problem... this is so frustrating...
Posts
1245
Registration date
Thursday October 7, 2004
Status
Contributor
Last seen
November 4, 2010
- Feb 18, 2008 at 11:16 AM
0
Thank you
Maybe you are out of range. Try closer. If that don't change anything, check your setup.
0
Thank you
Hey Benno,

Thanks very much! I spent hours trying to figure this one out, and you hit it right on the nose.

Aloha,
-mkr
0
Thank you
Same here, I fixed it in 5 minites and cruising. You are LEGEND
I've got all WPA-PSK settings made on the router. The WLAN light on the router is one, but my IBM Lenovo does not display the network when I try to find it. Thanks in advance!

Mike
Mikey B. > Mikey B. - Mar 1, 2009 at 01:54 PM
The WLAN light is on* not one.
Benno > Mikey B. - Mar 20, 2009 at 11:29 PM
Mikey -

Do you have any other wireless devices that can see the network? I know all Lenovo laptops have either a Function-F-Key combo or a physical toggle switch for turning off the wireless radio. If you can verify that the network is up and broadcasting an SSID, the issue is likely with your PC or its wireless card.

Cheers,

Benno
0
Thank you
Same problem, laptop worked on prior wireless router - just upgraded to D-Link DIR-655 - but can't find the old network name in Advanced. Still getting the error message.