Can't get Aspire One D255 to connect to wifi

Sally - Nov 8, 2010 at 01:13 PM
 Zaman - Apr 25, 2017 at 08:50 PM

I have just purchased an Acer Aspire One D255 but it just won't connect to my wifi router. The wifi light is on (orange/red) on the netbook. My router is on. But each time I try to connect it says 'Limited Access' and won't actually connect to the Internet.

Help! What am I doing wrong?



5 responses

I've found that updating the wifi card driver has worked stupendous. Its an Intel wifi card so go to find drivers and downloads click on wireless networking>Intel WIFI Products>Intel WIFI Link 1000. Install after download and Boom issues fixed!
Wow I had to just post this to thank Jumpa for that solution. My friend's Acer Aspire One D257 just would not connect to the internet and this solution worked when nothing else would. If you don't mind Jumpa, I'll clarify the fix for Windows 7 users.

1) Right-click on the wireless network icon next to time/date
2) Select 'Open Network and Sharing Centre'
3) Click 'Change Adapter Settings' on the left
4) Right-click 'Wireless Network Connection' and go to properties
5) Uncheck all the boxes except for 'Internet Protocol Version 4 (TCP/IPv4)
6) Click ok

It wouldn't hurt to update the wireless driver as well though.
Ambucias Posts 47357 Registration date Monday February 1, 2010 Status Moderator Last seen February 15, 2023 11,180
Dec 4, 2013 at 05:43 PM
Dear Pest

Thank you for your feedback. You are a swell pest.
the trick is to find a right driver. For me it was Atheros driver for AR5B95. Hope it will help...
Thank you so much Pestul! It WORKED! :))))
Thankyou, worked for me too. :-)
Thank you
OK here's the fix for the ACER ASPIRE ONE D255 With XP or W/7 Right click wireless connector ,bottom right near clock / open network connections/ advanced/ advanced settings / make sure all bindings for wireless connection are checked off / hit ok or apply you dont even need to reboot

Thats what was wrong with my fiancées Acer D255, What the driver does That "Dev's talking about" is, it turns these settings on so either way thats what worked for us & thanks Dev I was just pulling out the flash drive with both the 35 meg and the 7 meg drivers you talked about when she figured it out!
Good luck 7 please let us know if that helped you out
Rick & Tiffani
Your tip about the unchecking the settings in advanced settings did the trick. AOK! Thx mucho.
having the exact problem in here with a brand new d255...what is a binding?? so far I have added tls 1.1 and tls 1.2 to the checked boxes with no luck...called acer twice and been told to contact my provider, even though I told them my other laptop works fine!!! what a bunch of idiots!!
put a check mark in all the boxes
Dont buy Acer aspire, they are junk and tech support blames everything on the network connection when it wont connect to wifi. There support people are inept
just trying this now - hope it works and will let you know as have SAME problem!!
Your a frikin genius lol... It works.. Just uncheck everything except tcp protocol

Didn't find the answer you are looking for?

Ask a question
what is the logo of wireless connector? is it the same with Networks and sharing Center?