.NET Framework 4 interface not supported [Closed]

Report
Posts
214
Registration date
Sunday October 3, 2010
Status
Member
Last seen
October 18, 2013
-
vista.ultimate.64
Posts
214
Registration date
Sunday October 3, 2010
Status
Member
Last seen
October 18, 2013
-
Hello,

Im trying to install 3D studio 2012 but it required .NET Framework 4 +. It comes with it, but when I install it I get this error, Installation Did Not Succeed. No such interface supported. I went to the log file and got the info at the bottom. I tried downloading it from Microsoft.com and got the same thing.

I'm running Vista Ultimate 64 bit SP2

I know I have the hardware capabilites so it cannot be that. How can I install .NET Framework? Thank you.


OS Version = 6.0.6002, Platform 2, Service Pack 2
OS Description = Vista - x64 Ultimate Edition Service Pack 2
CommandLine = I:\be8d58d47006d791034b37ddd5cc63\\Setup.exe /promptrestart /1033 /x86 /x64
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4 Setup
Package Version = 4.0.30319
User Experience Data Collection Policy: Disabled
Number of applicable items: 12
Exe (I:\be8d58d47006d791034b37ddd5cc63\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (I:\be8d58d47006d791034b37ddd5cc63\Windows6.0-KB956250-v6001-x64.msu) failed with 0x80004002 - No such interface supported .
Final Result: Installation failed with error code: (0x80004002), "No such interface supported " (Elapsed time: 0 00:00:39).

2 replies


Hi,

Try this one:

https://www.microsoft.com/en-us/download/details.aspx?id=17718

If not then right click and run as administrator.

Good luck
Posts
214
Registration date
Sunday October 3, 2010
Status
Member
Last seen
October 18, 2013
30
Hi, thanks for the response and sorry for my late reply.

I tried what you said with and without administrator mode, I have UAC off. No luck, the stand-alone installer seemed to have the same problem. It can verify everything fine but before anything starts in the second bar, it fails.

Thanks for the reply. I hope we can fix this.