Hp pavilion dv4 2140us blank screen REPOST

Closed
Ashmeed Posts 5 Registration date Saturday August 27, 2011 Status Member Last seen August 28, 2011 - Aug 28, 2011 at 12:44 PM
 Ashmeed - Jan 14, 2012 at 06:55 PM
Hello, Hello, I have a dv4 and owned it for 1yr or so an I play alot of pc games on it an recently it started to give me blank screen even at the start up.So I thought is was the GPU.I use to hear it boot an when I leave it on for 20mins then shutdown an restart the screen would show normal.But now I t don't show at ALL...no video though LCD but it works perfect through the HDMI or VGA........i don't know what to do how to fix it because I opened it an cleaned everything an put new thermal paste on CPU still Having problem now.... an by the way 4 you who own HP laptops ..HP stopped manufacturing parts 4 it now....Anyhow But can you guys help me I really need my laptop to work through it's LCD not VGA or HDMI.Any help will be greatly appreciated.Thank you in advance

6 replies

xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,828
Aug 28, 2011 at 03:56 PM
Since the video works OK for an external monitor. Then, the problem is in the screen, backlight or inverter. I suspect you need the services of a qualified repair tech. I don't recommend that end users try to dismantle their laptop screens. Way too much can go wrong. The problem is fixing an old laptop can cost more than buying a new one.

Good Luck
0
Ashmeed Posts 5 Registration date Saturday August 27, 2011 Status Member Last seen August 28, 2011
Aug 28, 2011 at 04:10 PM
Thank you for the advice appreciated much....but r u 100 percent sure it is the screen??Because sum time it comes up an then other times no display...but I'm going to use it now on a sony bravia 32 inch through HDMI an see how it works...And one of my friends that works at computer store told me it was a simple capacitor for the LCD that is the problem.
0
xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,828
Aug 28, 2011 at 06:12 PM
100% sure it's broken - zero percent it's anything above or below. It's takes a qualified tech with the right equipment to diagnose. I suggest you pay someone to do that diagnostic.

screen, backlight or inverter
Or the cable from the motherboard to the screen.

It's probably the inverter but it takes hands on testing (with the right equipment and knowledge) to diagnose.

If you shine a bright light at an angle to the screen - can you see a faint image? Then it's the inverter.

If the screen comes-up when the lid is partially open/closed then it's probably the cable.

Good Luck
0
Ashmeed Posts 5 Registration date Saturday August 27, 2011 Status Member Last seen August 28, 2011
Aug 28, 2011 at 06:55 PM
you don't see anything when I put on the computer at all now.I jus play need for speed on sony bravia using HDMI output,works just fine.But I shine a light on the screen you get no faint image so I don't think it is the inverter ....what other sighs must I look for???thank you for your help
0
ashmeed the problem is not your lcd for certain.....dont go and buy a lcd just yet...I have the same problem with one that I am currently repairing .

Xpcman...i dont know who you are but my advice to you is if you want to help do help...but if u r not right infront of the problem u can not be 100% ... especially when money has to spend....last thing you want is that u give incorrect advice that makes ppl spend money and still ahve the same problem...thx for your imput none the less
0
xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,828
Sep 17, 2011 at 02:13 PM
Please note that I listed the cable as a possible problem and I did at no time tell them to buy a new screen:

100% sure it's broken - zero percent it's anything above or below. It's takes a qualified tech with the right equipment to diagnose. I suggest you pay someone to do that diagnostic.
0

Didn't find the answer you are looking for?

Ask a question
ashmeed
from the test I did it more looks like your lcd cable has gone faulty...
try ebay for a used one as its cheaper...
let me know
0
Thank you all for your help ...but I am going to get it checked by a proper technician an see what is the problem....until then hold on for my answer thanks in advance
0
wondering if you ever got it checked.... If so please post the cause and what was needed to be fixed. I am interested in what you find out. I too have the same issue.
0
Well I just got a used screen from a friend and installed it and it worked perfectly ......in fact rite now I am typing on the same laptop.In conclusion it most likely was the inverter.But for sure nothing is wrong with your board it;s the screen.?Hope this helps.My advice is 2 get a whole new or used screen meaning the whole entire top part of the laptop
0
Well I just got a used screen from a friend and installed it and it worked perfectly ......in fact rite now I am typing on the same laptop.In conclusion it most likely was the inverter.But for sure nothing is wrong with your board it's the screen.?Hope this helps.My advice is get a whole new or used screen meaning the whole entire top part of the laptop
0
Thanks a lot for the quick response. My last cheap option before getting a new screen will be to replace the actual lcd cable.
0
no problem
0