My computer does not recognize my scanner

[Closed]
Report
-
 suzannev42 -
Hello,

I have a Canoscan 4400F that used to be plugged via USB to my Windows 7 computer and worked perfectly. This computer has stopped recognizing the scanner suddenly. If I unplug the scanner and replug it, I do not hear the little sound that indicates that a new hardware has been found, nor do I see any window saying that new hardware has been found. I thought that my scanner was broken but when I plug it to all my other computers, some running XP and some running Windows 7, all of them make that little sound and a window pops up saying that new hardware has been found. I have 8 USB ports on my computer and I have tried them all to no avail. I have tried changing the USB wire, nothing doing. All my other devices (printers, mouse, wireless router, etc.) are recognized by the USB ports on my computer. It seems to be specific to that particular scanner. I have gone to Device Manager and all my USB ports are said to be working properly. I have unistalled the Canoscan drivers and re-installed them. I have closed the computer and re-opened it with the scanner plugged, and done the same with the scanner unplugged. Nothing makes any bit of difference. The computer acts like I am plugging nothing into it. Can anyone help??? Thanks.

1 reply

Posts
18
Registration date
Wednesday August 5, 2009
Status
Member
Last seen
April 10, 2012
8
do u have any usb device aside from scanner? if yes try to unplug all and plug your scanner.

and also check you bios to enable usb 2.0
I have tried unplugging all and plugging my scanner. Nothing doing. The scanner is not listed in device manager and not recognized. I do not know how to check my bios. Moreover, all other USB devices that I plug into each of my usb 2.0 is readily recognized and works perfectly.