I am having a problem autoplay drive

[Closed]
Report
Posts
182
Registration date
Monday July 25, 2011
Status
Member
Last seen
November 3, 2015
-
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
-
Hello,

I have two WD hard disks, which are both my Passport. Also, I have another WD, which is elment'

The WD my passport hard disks contain folders and files(such as setup files for Smartware and manuals) came inside them from the factory. However, WD elments doesn't contain.

I have installed a program which came only inside the hard disk'WD my passport', but not WD elment. That program is 'WD smartware', which is used to make a backup automatically, earse the hard disk and let me see view quick of drives and other tasks.

Whenever I connected the drives, I saw this message below:(This file doesn't have a program associated with it performing this action)

http://img248.imageshack.us/img248/6418/20130301000000.png


However, when I connected another hard disk drive, which is from another company 'WD elments', I didn't see such a message. However, I see that the hard disk opens automatically with some options.


Why does the WD elments hard disk opens automatically with options below whenver I connect it. However, the WD my passport don't and I only see the error message of associations.
http://img132.imageshack.us/img132/6236/201303010000002.png


Moreover, when I erase the hard disk with WD Software associated with the WD my passport hard disks to make an automatic backup and other tasks. Then, I disconted and reconnected the hard disk to my computer, I saw that this above windows contains options was shown::

NB: I have made a copy of these files to my internal hard disk before erasing the hard disk during WD Smartware which I installed from hard disk.

However, when I return agian and put a copy of the files(files higlightened in this screensho) coming from the factory in the hard disk. Then whenever I connect my hard disk, I see this error(This file doesn't have a program associated with it performing this action). Also, when I delet them, I saw the autoplay opens well.

http://img823.imageshack.us/img823/3831/20130303000000.png

So, I think that the problem with putting these files in the hard disks.

Also, I made sure that I installed 'WD SES' which is used to enhance the deal with the WD my passport hard disks. 'WD SES DEvices', which is under the catogary 'WD drive management devices' in the device manager, is installed. However, there isn't WD SES Device' for WD elments hard disk.






5 replies

Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
45
Hi,

Please try to update the "WD SmartWare" and check if the issue is fixed. For detailed instructions on how to update "WD SmartWare", please check the below mentioned link:

http://www.wdc.com/wdproducts/wdsmartwareupdate/wdsmartware.asp?id=wdfGeneric&os=win

Please follow the instruction on the page to install "WD SmartWare".

Do reply with results.
Posts
182
Registration date
Monday July 25, 2011
Status
Member
Last seen
November 3, 2015
3
Thank you so much indeed for your reply.
I've found out recently that :
While I connect my passport hard disk, I see these two auto play windows open. Sometimes, I found the options of auto play are inactive, after a little while the error association shows me. Other times, when I click on one option of the auto play, I see that the option executes

http://img20.imageshack.us/img20/4567/autoplayj.png

By the way, the version of my Smartware is 1.6.2
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
45
Hi,

Please update the "WD SmartWare Update Windows release 1.6.5 (updated 3/5/2013)" and check if there is any difference. You can download it from the below mentioned link:

http://www.wdc.com/wdproducts/wdsmartwareupdate/index.asp

Do reply with results.
Posts
182
Registration date
Monday July 25, 2011
Status
Member
Last seen
November 3, 2015
3
Thank you so much
I promise that I'll try this,
By the way, could you tell me



unlock program opens auto play inside another removable drive(Unloack security) whenever I connect my passport hard disk:: Why does there another removable device show while connecting my passport?

From where does it take the space of this device?

http://img600.imageshack.us/img600/6152/unlockd.png
Posts
2368
Registration date
Sunday September 23, 2012
Status
Member
Last seen
December 13, 2018
45
Hi,

This is normal, when you plug in the Western Digital Passport drive, you will see an additional drive appear in Windows Explorer (My Computer). The unlock.exe program will be on this drive. The WD has two drives (a small one with unlock.exe) and the main drive. Even when the main one is locked, the small one will be accessible so that you can run the unlock.exe program and open up the main drive. For more details you can visit "WD Smartware FAQ" page:

https://community.wd.com/t/wd-smartware-faq/26969#M1818

Please revert for clarification.