Regarding unhiding folders in a hard drive [Closed]

Posts
2
Registration date
Thursday February 28, 2013
Status
Member
Last seen
May 2, 2013
-
Hello,

As you said when I am entering the path:

attrib -h-r-s/s/s/d d:*.*

here d is my hard drive.

it is showing as invalid switch -h-r-s/s/s/d d:*.*

can u help me pls?

System Configuration: Windows 7 / Chrome 24.0.1312.57
See more 

1 reply

Posts
6498
Registration date
Sunday June 6, 2010
Status
Moderator, Security contributor
Last seen
December 30, 2015
1771
0
Thank you
Hello,

Try this 1

Make sure that you have given space between the attributes and the

command.

If you are using Windows 7 then

Click on Start --> In search bar, type cmd. When cmd appears in the search,

right-click on it and select "Run as administrator".

Since you have mentioned that its a D-Drive

Now enter the below command.

attrib -h -r -s /s /d d:\*.*

Make sure you have enter the command correctly with spaces between the

"command and -h -r -s /s /d also a space before your drive letter". Otherwise

invalid switch message will appear.

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note :
Replace the letter d with your drive letter where files are hidden.

Now check for your files in that Drive.

Good Luck
Hi
I have done with same procedure as you said. Its showing me

ACCESS DENIED - G:\ RECYCLER\ ..... AND SO ON.

HOW CAN I SOLVE THIS?

DO WE HAVE ANY OTHER SOLUTION FOR THIS?
jack4rall
Posts
6498
Registration date
Sunday June 6, 2010
Status
Moderator, Security contributor
Last seen
December 30, 2015
1771 -
Hello,
Try this 1
There are some folders where user don't have access to it. For such folders "Access Denied" message will appear. Just run the command and wait for the process to get completed.
Another alternate way is
Click on Start --> In search box, type control folders and press Enter.
[If you are using Windows XP then type control folders in Run and press Enter]
"Folder Options" will be opened. Click on the "View" tab.
Now select the option "Show hidden files, folders or drives" and uncheck the
check box "Hide protected operating system files" --> Click on "OK" button.
Now look for your files in your external drive.
Later undo the changes you have made by once again going to "Folder Options"
--> Click on "View" tab and click on "Restore Defaults" button --> Click on "OK".
[Note : Typing in caps is considered as yelling.]
Good Luck
Hi
Thanks jack. Recovered all the data. And one more small info needed. when I was clearing the virus files in the hard drive , accidentally I deleted recycle bin also. how can I restore it?
Hi Jack,
Thanks for the tips for recovering the hidden file from my flash disk. However, instead of using attrib -h -r -s /s /d as you've explained, i'm using attrib -h -s -r /s /d .
Though I don't know the difference impact between those two commands. But it works on my windows 7 .
Thanks again