How To Stop cmd Opening To A Open With Dialogue Box - Run cmd

slickery Posts 2 Registration date Friday June 14, 2013 Status Member Last seen June 14, 2013 - Jun 14, 2013 at 02:21 AM
slickery Posts 2 Registration date Friday June 14, 2013 Status Member Last seen June 14, 2013 - Jun 14, 2013 at 11:40 AM
Im Using Windows XP3

My Problem is that
When I open cmd from run command it always open To A Open With Dialogue Box

im not really sure if its my term to run command its correct
so here a detail one

Start --> Run --> cmd then enter or okay
This is my problem ------> It Will Prompt Open With Dialogue Box
Instead of Opening cmd directly

Well I Can open cmd From window/system32/cmd and Accessories without any problem

its Just that Im Used to Opening it
From Run Command

Cause by a Virus - Well The Virus is already Deleted
it surely is a troublesome virus it hides every files i got
well ive restored everthing except from the last problem
Running cmd to Run command normally

How do i fix that so that it will open automatically when i run cmd to run command

Anyone Please Help

Ive Already Tried This
Deleting cmd\1 and mrulist - only the cmd
well i bring it back to the way it is since it did not solve my problem

Default - "%1" %*
I Did not Change Anything here since the value is the same
when im following the instruction from other sites
this does not solved the problem either

This is what i used to fix my problems
using killgodzilla.exe - didnt not solve the problem
but it help me to fix the folder option and regedit being disabled

I used this command attrib -s -h /s /d *.*
To Bring back the my hidden files caused by the virus
I wonder if this was the cause not sure though but it did happen
after i used this one since its working the run command then cmd
until i used this one or it could be just a coincidence
well it happens after i close the cmd
Then the next time that i opened cmd it start showing up the dialogue box
well i dont have problem opening reg edit,word and others
just problem on opening cmd on run command

Dont Recomment to format my drive for the fact that i have lots of files
and since my anti virus take care every one last virus that igot

and since its just a one more step to completely reviving my system
just one problem to solve
run command --- cmd to open normally not with open with dialogue box
such a troublesome problem for me annoying one
dont want to create shortcut since there are lot of kids here that keeps openning everything i might end up with even bigger problem if i do that so no to shortcut

Any One Please Helpppppppppppp Thanks

1 response

jack4rall Posts 6428 Registration date Sunday June 6, 2010 Status Moderator Last seen July 16, 2020
Jun 14, 2013 at 10:07 AM

Try this 1

Click on Start --> Run --> Type regedt32 and press Enter.

"Registry Editor" will be opened. First backup your registry by clicking on

"File" --> Export --> Save the file with any name in your desired location.

Now at the left-side, navigate to the below location.


Windows --> CurrentVersion --> App Paths

Now right-click on "App Paths" folder --> Click on "New" --> Key.

Now a new key(folder) will be created. Name it as cmd.exe.

Now click on created "cmd.exe" key (folder).

At the right-side, double-click on the "(Default)" --> In the "Value data",

enter the complete location of cmd prompt as given below.


Click on OK.

Right-click on the white space --> Click on "New" --> String.

Name it as Path. Double-click on Path and

enter the "Value data" as C:\WINDOWS\system32

Click on OK.

Now close the registry editor and try to open the command prompt from "Run"

by just typing cmd and pressing Enter.

Good Luck
slickery Posts 2 Registration date Friday June 14, 2013 Status Member Last seen June 14, 2013
Jun 14, 2013 at 11:40 AM
Wow Thank You So Much It Works

Yeah Problem Solve Thank You Very Much