Western Digital Elements External HDD

[Closed]
Report
Posts
1
Registration date
Friday February 20, 2009
Status
Member
Last seen
February 21, 2009
-
 Patti -
Hello,
My Western Digital Elements External 320g HDD is playing up and I need some Advice. I disabled fire wire and tried tweak UI and both of these didnt work. We tried using a sata cable and connected it to my bf's pc and his pc crashed. I'm running XP and service pack 2 on a laptop. I plug my western digital in to my USB and the light stays on the HDD. It takes a few goes of unplugging and re plugging it in, but windows installs it and it's recognized in the system tray and when you go in to my computer its not there. Can some one tell me whats going on with it and suggest ways to fix it because it has very important stuff on it I really need to get back. Thanks for all your advice.

Sonja

3 replies

I am having a similar problem. When I plug my 640G WD mybook into the computer at work, it recognizes it and the message pops up saying that it's ready for use. But when you go to my computer there is no folder or anything to open the HDD. The autorun doesn't come up either, so I can't open the folder from there either. The thing that makes it odd is that I also have a 1TB mybook and when I plug it into the same computer it works fine. One more thing to make it weirder: when I go around the office and try the 640HDD in other PC's, it works fine. So what would be stopping me from accessing the 640 on that PC, when the same PC lets me open my 1TB?
5
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

This could be due to the USB cable being used. These devices does not have external power and draws their power from the USB connection. Older computer may not have sufficient power delivered with the USB port.
Use the cable that came along with the HDD

Did any thing change with the Cable
Did you try with another computer
Do not use the USB Cable Extension....as the USB may not have enough power to run the HDD connected with the longer cable....note...long cable = more power loss.


Thanks
Shree
hey sheree / i had a similar problem like your describeing after 4 long days and nights trying to work out what happened i gave up and got a recovery programme called getback data for ntfs it was so easy to use i saved all my stuff on hard drive to another external hard drive then deleted and reformatted to ntfs took some time to dooo the transfers over and a little trick was to attach the hd to a internal ide strapp on its own with no other component attached to the strapp the system recognised it and the getback data programm found and retrieved all i needed be sure to do disk check and fix file and sector errors from the windows basic disk check options then bobs your uncle . you need to install programm as administer and turn the uac off then rebooot and do the job you need to doo . hope it helps you to get ya data back cheeers , :) Cazzar
I had a problem with my external Elemnts drive, the system would recognize it, then I couldn't get it to be recognize it after that. I finally figured it out that it was because of the indexing of the drive's contents that was causing the problem I'm on a Mac, so I just unchecked all the boxes in the Spotlight System Preferences panel, drive was recognized just fine after that. I know Windows has an indexing service so perhaps turning it off would help?

Good luck!