Faulty hard drive

Closed
pcchris Posts 1 Registration date Sunday January 26, 2014 Status Member Last seen January 26, 2014 - Jan 26, 2014 at 07:41 PM
 pcchris - Feb 2, 2014 at 08:48 AM
hello, i'm new here so please be patient with me, I have a Hitachi deskstar, model HDP725016GLAT80, I have this 3.5 inch drive mounted in a caddy case, connected via usb, has been working fine until today, plugged it in and it take about 5 minutes to be recognised in my computer but even when it appears in my computer it still on show drive E: with no size or detail if I right click properties it appears to have no detail about the drive other than E: If u go to windows disk management it is there however again with no detail other than 149GB it shows the drive no partitions just one long square box with nothing in it just 149gb listed on the left hand side, I tried downloading a diagnostic tool from hitachi but it wouldn't recognise it at all, also when the drive appears in my computer if I am to try and open it it take for ever then the page is not responding appears, also I cannot safely remove the drive as it says it is still in use. any help on recovering my folders would be much appreciated ps I have tried within a known working enclosure and also on three other pc's it does them same on all, thanks
Related:

1 response

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,832
Jan 26, 2014 at 08:52 PM
Most file recovery programs don't work well with USB connections. Can you connect the drive as an INTERNAL drive on a desktop?
0
Hi I have connected it up as a slave within another deck top but it has done exactly the same thing, any further ideas will be mush appreciated thanks
0