Itunes registry settings missing [Solved/Closed]

ekb7 - Mar 12, 2009 at 11:23 PM - Latest reply:  Nitwit13
- Mar 25, 2018 at 07:21 AM
Hello,
I downloaded the most recent Itunes onto my inspiron 1525 laptop with windows vista. When I do so shortly after using it a message comes up saying that the registry settings on Itunes is missing. I have tried re-installing Itunes and installing GEAR drivers. Both have worked, but only for a very short amount of time. Each time I do this I then have to delete my lower and upper filters on my computer because the CD/DVD drive won't show up. It just keeps going into this back and forth cycle and I don't know how to fix it. Please help! Thanks!
See more 

90 replies

+181
Helpful
55
Here is what I did to fix my problem with itunes registry settings missing and I couldnt burn cds.

. Make sure you have iTunes inslled (and if you uninstalled the GEAR driver reinstall it) Ok now go to the registry (start->run->regedit.exe) and look for "HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}". Right click in the right section and select "New->Multi-String Value". Name it "UpperFilters". Right click on it and select "Modify" Enter "GEARAspiWDM" 9press enter to move to the next line and click ok) into the "Value Data". Restart and Voila it should be fixed. If not also try to make a "LowerFilters" and leave it blank.

I tried alot of other things but this worked, I have Windows xp
good luck
Was this answer helpful?  
Many thanks it cleared the opening message - just need to fix the cd burning software message now
This solution works
ConanTheRepublican - Apr 7, 2015 at 09:12 AM
Worked! Freaking awesome.
Microsoft instructs to delete the values - but only this thread explains how to replace them to get the damn thing to work. Thank you.
This also helped me after MONTHS of issues.
+14
Helpful
2
For Vista, none of the missing DVD/CD fixes worked, or some worked for Windows and not for ITunes, or vice-versa. Finally, found the real Vista issue:

http://www.gearsoftware.com/...

Nothing to do with Windows or ITunes at all - some lame 3rd party software with old drivers (AFK.SYS) causing the problem... Renamed and everything works...
This was the only fix that worked for me. I tried everything else listed, this finally did the trick. Thanks UK-Kid! I have been looking for this fix for almost two years. I finally have my drive listed on my computer, and can burn CD's from iTunes. I am almost in disbelief.
DUDE! You ROCK! THIS FIXES BOTH ITUNES AND VISTA CD PROBLEMS!!!! NONE OF THAT OTHER FILTER CRAP WORKED FOR BOTH ITUNES AND WINDOWS!!!!! UKKID IS MY HERO!!!!
+8
Helpful
1
I was able to fix the problem by updating my Gears drivers here:
http://www.gearsoftware.com/support/drivers.php
Thanks been at this problem for two days now using the above on WIN XP pro
+7
Helpful
3
Follow the above steps for instealling gear but follow this last step before rebooting your PC. It won't permantly solve your problem as I've had to deal with it more than once, but it will provide the fix to allow itunes to go back to normal. I found this somewhere so it's not not my resolution. I wish I could remember where I found it to give proper credit, but more people should know about this because even after doing all the registry changes and reinstalling GEAR, my itunes would not work until I did this.


• Good news!!!!I have had the same problem as you and have been dealing with it the last 2 days-uninstalling itunes,quicktime and then reinstalling and installing gearproduct download??Anyway to make a long story SHORT:
1. Do a search for a file -GEARAspiWDM.inf in C drive
2. Right click and install
3. Reboot the computer
4. itunes should be working without the error-I hope, it worked for me!!!!!!
good luck, K
kenny47 2 Posts Sunday January 10, 2010Registration date January 11, 2010 Last seen - Jan 11, 2010 at 11:25 AM
HI.THANKYOU VERY MUCH FOR THIS SOLUTION.IT WORKED LIKE A CHARM.KENNY47
Thank you so much CWalrus. I've been all day trying to fix this and your solution worked. I did sort this out 3 months ago but recently installed an Epson Scanner which messed up the drivers for cd burning. Now I have to sort that out too!!
Tried everything else and finally this worked. Dont know where you found the fix, but GREAT JOB!!!
+3
Helpful
1
Had the same problem, downloading the GEAR driver fixed it instantly. I'm guessing that I was a little too careless with my program removal or system cleaning.

Thanks for the help.
I had the same problem with iTunes and Vista and just fixed it by downloading and installing the GEAR driver at: http://www.gearsoftware.com/support/drivers.php
+2
Helpful
1
I hate to be the one to say that this fix didn't work for me :( I tried it numerous times & I still get nothing. My cd drive completely disappears or I get it back & I still can't burn cd's in iTunes. Someone help, please!
I am having the same problem. If I update the registry, the iTunes error goes away, but so do my CD/DVD drives. If I change the registry back, I get my drives back, but iTunes gets the registry error again. I am running 64 bit
Windows 7 on an HP desktop.
dreamer 666 - Mar 10, 2010 at 10:23 PM
+2
Helpful
Shine, you're a genius. Thanks.
+1
Helpful
3
missing gear driver file
I am having the same exact problem. I have reinstalled the GEAR drive but my problem is not solved, Please, help. How do I pull up the registry?
type regedit in the search on Vista then click into that program.

I upgraded to Vista since my first post. I opened some old music files and it started saying the same
thing 'no disc burner found" I downloaded the gear driiver and it worked.
I wish they had another program for my ipod -I would get rid of itunes & never miss it
and all the problems

GOd Bless you all
Shine
thank you , thank you thank you shine! what a relief! I am so grateful for your helpful information. problem solved with your advice in 45 minutes vs, the entire week I have spent trying to fix, uninstalling and reinstalling. :)
+1
Helpful
NICE!!!! I had same problem, new gear driver install fixed the loss of my cd player. The question, why does itunes 8 remove this from registry? In device mgr (XP) it stated that registry has changed under the cd player and showed a caution. That's not cool.
Shine - your alright, thank you!
+1
Helpful
1
It worked for me on Windows Media Center
Thank you I have been on the phone with Apple for hours no help told me to call Microsoft they told me to call Apple
Thanks again
TBR
This was great it worked and was easy. Just go back and put the beginning parenthesis ( ) mark as it may be a bit confusing. Thanks for the excellent help.
+1
Helpful
AWESOME!!!

I have windows 7, installed the new drivers and then used "UpperFilters"

WORKS PERFECT!!!

Thanks Jazz_e!
Kris Fitz
+1
Helpful
Hi guys,
You can fix the issue by follwing the links:-

For Vista and Windows 7- http://support.apple.com/kb/HT2615
For Win 2000 and XP - http://support.apple.com/kb/TS2372
+1
Helpful
Thanks to everyone on this subject and especially to Shine, I now have both my CD burner and a normal iTunes.
It all worked fine in XP but just bought a new computer with Windows 7 Home Premium and first I lost my CD when I installed iTunes and then when a tech where I bought the computer removed the Registry filters I lost a lot of iTunes.

Now following the steps outlined here I have both, thanks to you all again.

(Especially Shine)
+1
Helpful
Another success using Shine's fix. Don't know how you knew what to do, but thanks a great deal. Three hours in, I found your post. Ten minutes later . . . done! All is well. Thanks
+1
Helpful
It is so great to have a problem and be able to successfully fix it. The "Shine" fix worked nicely and now I can cut a couple of CD's for my car. Thank you again............
0
Helpful
Thankyou so much this worked straight away!
jonny30bass - Dec 27, 2009 at 01:26 PM
0
Helpful
Thank you soo much! reinstalling itunes is not the solution.
0
Helpful
Hey Guys...I need help. I have this problem but I'm using Windows 7 and can't figure out how to fix it. Please help. Thanks a lot.
0
Helpful
I have tried this and got my drive back. Thank you. However, I cannot burn any discs using my CD/DVD RW. The Ulead software I am using is not recognising my drive. I am using Vista.
0
Helpful
Same here. Vista 64. Nothing fixes the problem totally. I even purchased another drive. Funny thing is one drive will read cd's but not dvd and the second drive will read dvd but not cd audio. Both are dvd/cd recorders. It is definately a software issue with vista 64 , itunes, or drivers because I removed both of my drives and installed in my sons xp system and they work flawlessly. At this point I still get the error when loading itunes but one of my drives will rip all the track slowly. The other drive rips only the first two tracks then skips to the last. Microsoft - Apple -man up and fix the problem.
1 2 Next
Itunes registry settings missing - page 2