PC turns on but doesn't show up on monitor.

Closed
CannibalisticYeti
Posts
2
Registration date
Friday February 12, 2016
Status
Member
Last seen
February 13, 2016
- Feb 12, 2016 at 11:38 PM
Ambucias
Posts
47362
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
- Feb 13, 2016 at 04:11 PM
Ive been dealing with this PC for months. Sometimes it works most of the time it doesn't. I've tried everything. I turn on the PC it starts, the fans start, everything looks like its working, but it doesn't show up on my monitor I've tried switching different HDMI ports, tried a different monitor, I even upgraded to a higher voltage power supply (700w), reset BIOS, and rearranged my RAM, still no luck. Here are my specs,

CPU- AMD 2.9 ghz x3

RAM- 6gb DDR3

HDD- 500 gb

PSU- 700w

GPU- MSI Twin Frozr Geforce gtx 660 Ti

OS- Windows 8.1 Pro

Help is gladly appreciated! Thanks to all!
Related:

1 reply

Ambucias
Posts
47362
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,283
Feb 13, 2016 at 05:24 AM
Hello

Have you tried a different graphic card?
0
CannibalisticYeti
Posts
2
Registration date
Friday February 12, 2016
Status
Member
Last seen
February 13, 2016

Feb 13, 2016 at 11:52 AM
Yes. Tried two different cards and still nothing.
0
Ambucias
Posts
47362
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,283 > CannibalisticYeti
Posts
2
Registration date
Friday February 12, 2016
Status
Member
Last seen
February 13, 2016

Feb 13, 2016 at 04:11 PM
Could it be your cable?
0