Keyboard types random characters [Closed]

Report
-
Ambucias
Posts
51392
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
January 20, 2020
-
Well not totally random - hitting any key repeatedly will cycle through all the characters in qwerty order. EG. Pressing 'q' will first display an 'a', then an 's', 'd', 'f', and so on. It worked fine earlier. Nothing changed as far as I know. It does this on the (HP) laptop keyboard and the Logitech wireless keyboard. Tried rebooting, removing batteries on wireless, etc. Mostly tried while working in Chrome and IE. Any ideas what is going on?

1 reply

Posts
51392
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
January 20, 2020
13,999
Dear Uncle Buck

Will it type wrong characters only while on Internet or with all of your word processing software?

Do you have a qwerty or acerty keyboard?
Ambucias
Posts
51392
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
January 20, 2020
13,999
Sorry uncle,

I just read that you are in qwerty.

Go to your control panel, check the language settings. Looks like you are on acerty, perhaps French language. Often in Canada they say!
It seems to be exhibiting this behavior only in the browsers, Chrome and Internet Explorer. I tried Opera – no issue there. I tried notepad, excel and word, those worked. I also remembered that I had set up parental controls two days ago, so I disabled those as well. No change. I’m on Windows 8. Keyboard layout is US, language is English (United States). No other keyboards installed (I removed Canadian Multilingual). Netgear router, using Netgear Genie for parental controls (OpenDNS).
Again, typing the same key presents a different character each time, following the qwerty keyboard layout but starting at various characters. Pressing the letter ‘a’ 13 times just now resulted in: nm,./-+\123456
Ok, I just turned off anti-key logging in Zone Alarm, restarted my browser, and seem to have stopped the 'random' characters. (I installed this antivirus software about a week ago). Not sure what to do next. Leave this feature off?
Ambucias
Posts
51392
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
January 20, 2020
13,999 > Uncle Buck
Zone Alarm was created in France. Yes I would leave the feature off.