Laptop won't turn on... Sometimes

Closed
Kerias
Posts
9
Registration date
Sunday April 24, 2016
Status
Member
Last seen
April 24, 2016
- Apr 24, 2016 at 03:05 PM
 MSI user - Jan 23, 2017 at 02:04 AM
Alright. To start, the 30 second power button thing doesn't work.
I have an MSI GE70 2PE APACHE PRO.
My laptop usually won't turn on. This has only been happening for a couple of days, but I'll try to give you the best details I can.
When I try to turn my laptop on, all that happens is the power light blinks on once. Sometimes, the computer actually turns on and works fine until I unplug the power source. But then it automatically shuts down. Directly after this, if I plug in my computer or try to turn it on using battery power, the button flashes orange once. Then I hold the power button down for thirty seconds. Then the color flashes blue once when I try it. After hours of leaving it alone, sometimes it will turn back on when I try it, but so far this has only been the case when it has been plugged in without the battery connected.
When this first occurred, the computer was very warm before it shut down without warning while plugged in.
What do you think the problem is? Is it the power brick, the battery, the motherboard, or something else?
Any help is greatly appreciated! Thank you!

3 replies

xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,967
Apr 24, 2016 at 03:24 PM
MY best guess is it's a motherboard problem.
0
Kerias
Posts
9
Registration date
Sunday April 24, 2016
Status
Member
Last seen
April 24, 2016

Apr 24, 2016 at 04:44 PM
ok well I really want to know why this is happening, so like why I would have to replace the entire motherboard before I do that
0
I have same laptop And exactly same problém but when i try to turn on PC it show MSI logo And after 3 sec it turn Off immediately.it Just start for no Reason this problém i Just that day turn off PC everything was normál And after 2 Hours later it start doing this. And PC start only after Hour i think.
0
Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,314
Apr 24, 2016 at 05:08 PM
I agree with Xpcman, it looks like motherboard failure, probably in the power supply unit. I can't say why this is happening, parts and circuits do wear out.
0
xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,967
Apr 24, 2016 at 08:03 PM
capacitors have a history of failing. There were lots of junk capacitors from China a few years ago. Be aware that motherboard replacement may cost more than a new laptop.
0