Report

USB flash drive won't open any of it's files [Solved]

Ask a question Saba - Last answered on Apr 29, 2013 01:54PM
Hello,
I've got a problem with my USB flash disk. When I open it, none of my files are on it. I've installed the driver and I copied a few files on to it this morning but when I inserted it after a few hours, it was empty. But in properties it says that theres 1Gb used and 3 Gbs free space but there are no files on it. None of the files are hidden either so they should show up. I uninstalled and reinstalled it but its still not working! What should I do?? I would format it but I don't have another copy of the files on my USB and I cut and pasted so I can't get them back from the recycle bin. Afterwards I moved a few files on to it and it would show them but not the old files. I also opened its properties and went to hardware and it says that the device is working properly.
If you know what the problem is, please help me...I really need the files...
Thanx!
See more 
Helpful
+25
moins plus
You may find this post helpful:

http://ccm.net/forum/affich-28692-how-to-retrieve-lost-files-in-flash-drives
Saba- May 26, 2010 01:36PM
THANX!!! :)
Reply
mrrigga 196Posts Wednesday May 5, 2010Registration date ContributorStatus July 14, 2010 Last seen - May 26, 2010 03:40PM
Your welcome hope it done the trick
Reply
meatfactory- Apr 29, 2013 01:54PM
Or you can use winrar ;)
Reply
Add comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!