Report

Pendrive G:\ is not accessible I/O device error' [Solved/Closed]

Ask a question Anonymous User - Last answered on Sep 24, 2016 06:45AM
My PC detects my 16GB KINGSTON pendrive, but when I try to access the device, the following message is displayed:

'G:\ is not accessible. The request could not be performed because of an I/O device error'


I already tried to format the device, but it won't do. So are there any solution to repair my device.
See more 
Helpful
+0
moins plus
Hi sushmasridurgaDonthamsetti,

Unfortunately the I/O device error may indicate a serious problem with the pendrive. I would recommend you to test the device on another PC. Does the problem exist? If the same error appears, you may need to change the pendrive. Sadly, these kinds of issues are not repairable.
If the drive is working fine on another PC, you may need to open Device Manager and uninstall the USB hubs. Restart the PC and reconnect the pendrive. Any change?

Hope this helps

Helpful
+0
moins plus
thank you so much for your valuable information

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!