Report

WD book shows as not initialized

Ask a question soulless - Last answered on Aug 11, 2017 at 01:45 PM by _Soulless
Hello,
my WD book shows as not initialized in disk managment,but on my other pc it works fine.
See more 
Helpful
+1
plus moins
did you try All the USB ports? Sometimes laptops can't provide sufficient power to run full size desktop drives.
_Soulless 2Posts Monday July 31, 2017Registration date August 11, 2017 Last seen - Jul 31, 2017 at 02:44 PM
hello,
my WD book essential is mains powered ,also both my pc are desktops, and both have windows 7 , and yes i have also tried other usb ports , i have even reinstalled the operating system in case of any errors,my book shows in device manager and on the safety remove tab but not in my computer, but says not initialised in disk management.like i said it works fine on my other desktop, so its a bit of a puzzle.
Reply
Leave a comment
Helpful
+0
plus moins
hello
Solved it, seems
my WD book essentials was not powering up correctly, hence not showing in my computer and not initialized, soon as i purchased another external power supply it connected an worked fine ,as far as it working on my other pc it was working because i was using my sons power supply which was all ways plugged in so was more convenient to use rather than disconnecting mine , so my laziness was blinding me to what the problem was ,until xpcman mention insufficient power so all thx to xpcman .
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!