Monster displays no signal and PC keeps rebooting

Closed
Benjaminbb
Posts
2
Registration date
Tuesday February 20, 2018
Status
Member
Last seen
February 21, 2018
- Updated on Feb 20, 2018 at 07:50 PM
Benjaminbb
Posts
2
Registration date
Tuesday February 20, 2018
Status
Member
Last seen
February 21, 2018
- Feb 21, 2018 at 08:09 AM
Hey!
So at first a few weeks ago my pc turned on and my monitor was just fine. However suddenly my monitor displayed a black screen with “no signal”. I then proceeded to restart my monitor multiple times (the power on / off) button and it suddenely received signal. Then just today I decided to tackle the problem by vacuuming the outside and then proceeded to air spray the inside and reseated the ram since that was what was online as a solution. I took out my ram and used the air sprayer to clean out the dust and reseated the ram. I then sprayed that air sprayer into the mother board and all around to remove the dust. Right after I tried to turn on the computer and it then just keeps rebooting itself after 10 seconds or so and my monitor still receives no signal. I’ve also tried to reseat my graphic cards and still no solutions. Everything suddenly happen and I’m still lost on what the cause was.
Thank you!
Related:

1 reply

Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,314
Feb 21, 2018 at 05:39 AM
Hi

We are missing some info.

Your computer's make and model?

Your operating system?

Cleaning with a vacuum cleaner was a huge mistake. You have damaged your power supply, that's why it keeps rebooting.

It's time for a drive to the repair shop.

Good luck
0
Benjaminbb
Posts
2
Registration date
Tuesday February 20, 2018
Status
Member
Last seen
February 21, 2018

Feb 21, 2018 at 08:09 AM
Hey but I only clean the exterior? I only use the vacuum cleaner to clean the fan and that was it. It worked Fine until I decided to reseat the ram and spray my inside with an air duster and when I tried tor reboot it it then started cycling
0