Acer Laptop won't run

fares26597 2 Posts Tuesday June 19, 2018Registration date June 22, 2018 Last seen - Jun 19, 2018 at 09:09 PM - Latest reply: ac3mark 9999 Posts Monday June 3, 2013Registration dateModeratorStatus July 20, 2018 Last seen
- Jun 22, 2018 at 02:45 PM
I have an Acer Aspire E1-570

About two months ago, one of the screen joints stopped pivoting. Almost immediately after, I noticed that the screen would take from 5 to 15 minutes to light up. I dunno if they're connected, just mentioning it.

It's not just a screen problem. The Windows doesn't boot, not even the BIOS starts. As if there's no power, even though the power light is active and the laptop is naturally heating. I made sure when I connected another monitor with an HDMI cable. There was no difference.

I fixed the joint but the other problem remained. Lately though I would keep trying a whole day to start it up multiple times to no result. It would sometimes take hours, or even a couple of days of trying to get it running. I opened it up, cleaned it, took out the RAM, changed the Hard Drive, tried to run it without the battery. Nothing.
I also noticed that the fan sound is noticeable at first but then it quickly faints. I don't know if that means anything.

One friend told me that he thinks my GPU is screwed, but that's not something I want to hear. So I came here for a second opinion.

Any help is deeply appreciated.
See more 

Your reply

3 replies

Ambucias 53303 Posts Monday February 1, 2010Registration date July 21, 2018 Last seen - Jun 20, 2018 at 04:40 AM
0
Thank you
Try this

1. Remove the battery and cable.

2. Press and hold the power button for 58 seconds.

3. Replug and start.

Good luck
fares26597 2 Posts Tuesday June 19, 2018Registration date June 22, 2018 Last seen - Jun 22, 2018 at 02:30 PM
Unfortunately, that did not work
Respond to Ambucias
ac3mark 9999 Posts Monday June 3, 2013Registration dateModeratorStatus July 20, 2018 Last seen - Jun 22, 2018 at 02:45 PM
0
Thank you
Take the HDD and try to boot. What indication do you have that it knows the HDD is missing? If you get no indication, it is not POSTing, and it is fried!
Respond to ac3mark